dev-python/sphinxcontrib-spelling: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 13:49:50 +0000 (14:49 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 13:59:24 +0000 (14:59 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/sphinxcontrib-spelling/Manifest
dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-2.1.2.ebuild [deleted file]
dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-2.3.0.ebuild [deleted file]

index 371c991f58751cda263c63399c1314961e981db5..4403c6c3c41a99cddbb9fd954031a989af94d522 100644 (file)
@@ -1,3 +1 @@
-DIST sphinxcontrib-spelling-2.1.2.tar.gz 35411 BLAKE2B 9738e18664fb68f6f8f7aafb626b6712f7c30947681f6c5ed288dd76c2b24245cb4083887330fc05ef4fdc64756245d997797ae36899c2c762489fff13219a21 SHA512 993f371e064e8748eb61faae649fb293b154a35955ff84d86fd041f4e2cc4c6e22c686007a67c3b63b0c50fc01ed226708f27db347e58847a46ca733c997d51f
-DIST sphinxcontrib-spelling-2.3.0.tar.gz 35687 BLAKE2B 9b48f1953616875bd5f0106ab0a01ac22d176b93eca88da7e36804eaf744aaf6e941d3dcb9f905f9bfe54ea51eb5c0d14d954b3def809994e7ba661e09cdb18e SHA512 194023d2c5ba594a264740a2a45ebd90d37fc17fbd3bc8c53fa303581a652c58332f998a159c9c6c58718dd9898c9b4639e98ee114a2ee1e5f2097e545134a1a
 DIST sphinxcontrib-spelling-4.3.0.tar.gz 38316 BLAKE2B 4bfcbfb22c10b5bd181ef5ba7b64815ccaeaa50f01ccff96adab914cfbe6674ce28088e5eb5717b44531565f961b1f159014d235275065070e22d96d08cd4af2 SHA512 0d1575079be7994df905de02d31ad2c9c3af9634a487fbc9c565067fcbef6c36fd4fbd326ccbee4b40b3ff14696ad85a97c68018a956ff3e2f7e1be46bb3a074
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-2.1.2.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-2.1.2.ebuild
deleted file mode 100644 (file)
index 9bbc740..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Sphinx spelling extension"
-HOMEPAGE="https://bitbucket.org/dhellmann/sphinxcontrib-spelling"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-CDEPEND="
-       dev-python/pbr[${PYTHON_USEDEP}]
-       >=dev-python/pyenchant-1.6.5[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]
-       >=dev-python/sphinx-0.6[${PYTHON_USEDEP}]
-"
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( >=dev-python/sphinx-0.6[${PYTHON_USEDEP}] )
-       test? (
-               ${CDEPEND}
-               dev-python/nose[${PYTHON_USEDEP}]
-       )
-"
-RDEPEND="${CDEPEND}"
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_test() {
-       nosetests || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/build/html/. )
-
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-2.3.0.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-2.3.0.ebuild
deleted file mode 100644 (file)
index 4c610d2..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Sphinx spelling extension"
-HOMEPAGE="https://bitbucket.org/dhellmann/sphinxcontrib-spelling"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
-
-CDEPEND="
-       dev-python/pbr[${PYTHON_USEDEP}]
-       dev-python/pyenchant[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]
-       dev-python/sphinx[${PYTHON_USEDEP}]
-"
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
-RDEPEND="${CDEPEND}
-               dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
-"
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/build/html/. )
-       distutils-r1_python_install_all
-       find "${ED}" -name '*.pth' -delete || die
-}