dev-java/icedtea-web: Fix sandbox violation, bug #573060
authorJames Le Cuirot <chewi@gentoo.org>
Wed, 27 Jan 2016 21:44:58 +0000 (21:44 +0000)
committerJames Le Cuirot <chewi@gentoo.org>
Wed, 27 Jan 2016 21:48:36 +0000 (21:48 +0000)
Package-Manager: portage-2.2.27

dev-java/icedtea-web/icedtea-web-1.6.1.ebuild

index 0a3c79c24e78bd50fa594be3c9473136b8487067..651a655b27e6fc35699e9bcbc4305d621b9b82b0 100644 (file)
@@ -6,7 +6,7 @@ EAPI="5"
 
 README_GENTOO_SUFFIX="-r1"
 
-inherit autotools eutils multilib readme.gentoo-r1 java-pkg-2
+inherit autotools eutils multilib readme.gentoo-r1 java-pkg-2 xdg-utils
 
 DESCRIPTION="FOSS Java browser plugin and Web Start implementation"
 HOMEPAGE="http://icedtea.classpath.org"
@@ -65,7 +65,12 @@ src_configure() {
                $(use_with tagsoup tagsoup "${tagsoup}")
        )
 
+       # See bug #573060.
+       xdg_environment_reset
+
+       # Rely on the --with-jdk-home option given above.
        unset JAVA_HOME JDK_HOME CLASSPATH JAVAC JAVACFLAGS
+
        econf "${config[@]}"
 }