dev-python/trustme: Fix remaining MissingTestRestrict
authorMichał Górny <mgorny@gentoo.org>
Fri, 22 Nov 2019 11:28:23 +0000 (12:28 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 22 Nov 2019 11:44:27 +0000 (12:44 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/trustme/Manifest
dev-python/trustme/trustme-0.5.0-r1.ebuild
dev-python/trustme/trustme-0.5.3.ebuild [new file with mode: 0644]

index 81546b7913bcbb1eaa572f18538e1b82cc8cd6c2..31bb1697ea4e065206655f93fae060480155650d 100644 (file)
@@ -1,2 +1,3 @@
 DIST trustme-0.5.0.tar.gz 21232 BLAKE2B 3804fe4e9b7049da0bab926bb1180af6bbb8f882cfb16109bed040ca50c85e7b83b5468c3388dd8478ee9fc6478523bba98c39b74cb76c86a72761a26685122e SHA512 7ce5041b8d3687fa462fe93e55b2f83549ab805cec4a2a94c9178a02af557cf8900fe6c05bae0bf100eb36181952fb2bc31cb1d4d6ad6ed2fd2b0706d569518f
 DIST trustme-0.5.2.tar.gz 21819 BLAKE2B 68516eee909851f16c092cff580b1267e57aad5641014c7e1ff5da98fc328e1e392cf0e08d1965be062f2be1c16de735ddeff2dfbb2f20b1bb34498a1b048861 SHA512 32ab33a82752228aad200203b7b217f9b9da970067330a273c9ff5c13c8ae15ef20c39e61fc9cd748b7030691ef4b003f279a50374f59b7743c4c90aeca56a22
+DIST trustme-0.5.3.tar.gz 35946 BLAKE2B 4150ebd8efad9033333325ed8e0f0d0da713b196391f55018d913af904fbc889596470fc02ba51db2c732a733f5561ca207876344daba970509aab98978de3ac SHA512 ac898c8531d54fefeef53986916e196b9cc808fc9e388c26b23b3fbc596204421b2a072ac4f2ceb8f263383a942cccc4ad7b23c776536b63e671e7e9e2141ab0
index 9f868768a873a803005f98d7cb82e93243dedd27..9bb4bd6739ac1a6cc9e9ff2751fcf24a75ff50fb 100644 (file)
@@ -14,6 +14,7 @@ LICENSE="|| ( Apache-2.0 MIT )"
 SLOT="0"
 KEYWORDS="amd64 ~arm ~arm64 x86"
 IUSE="test"
+RESTRICT="!test? ( test )"
 
 RDEPEND="<dev-python/cryptography-2.7[${PYTHON_USEDEP}]
        dev-python/idna[${PYTHON_USEDEP}]
diff --git a/dev-python/trustme/trustme-0.5.3.ebuild b/dev-python/trustme/trustme-0.5.3.ebuild
new file mode 100644 (file)
index 0000000..10341de
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7,3_8} )
+inherit distutils-r1
+
+DESCRIPTION="#1 quality TLS certs while you wait, for the discerning tester"
+HOMEPAGE="https://github.com/python-trio/trustme"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="dev-python/cryptography[${PYTHON_USEDEP}]
+       dev-python/idna[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' -2 )"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/pyopenssl[${PYTHON_USEDEP}]
+               dev-python/service_identity[${PYTHON_USEDEP}]
+               $(python_gen_cond_dep 'dev-python/futures[${PYTHON_USEDEP}]' -2 )
+       )"
+
+distutils_enable_tests pytest