dev-python/colorama: Remove old
authorMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 10:27:18 +0000 (12:27 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 10:27:18 +0000 (12:27 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/colorama/Manifest
dev-python/colorama/colorama-0.3.9-r1.ebuild [deleted file]

index 7fe2f054d1058950aa9f3f52b1020d98238f9a4b..d3666422db8f00aa5383bf4c43dd045d66b08f87 100644 (file)
@@ -1,3 +1,2 @@
-DIST colorama-0.3.9.github.tar.gz 122180 BLAKE2B 0ef1b2876a8d790e434548649d34bc38940eb48883080168d11cca79fc17c2cab258831ac2660be69eca28000864d617cb4a448558f8e473bca22cce090a8e03 SHA512 7bf6ec19181431d91f5c7a5334d01f9934d4555004e985f82ad74fc325c465339a4c3fdf017af6e0682e0b22e2bf78938cd222b670e5035f305d2d616b03d1d1
 DIST colorama-0.4.1.github.tar.gz 104708 BLAKE2B 625c6ff325ff0de8113c5c9abe9dd296eb614b0483a2dce59b163431ec4ef1992073719160143b68e76d3ad77f77b975a110ce19496be1d8f6ee90b3f66b6e7b SHA512 006069859ca05ec8a6808860ca73ab541b246e6e6443b1bc8426973beaa5268660b48994f21edb6492fe97c4b9d29949b874b861ec200b1756d40e8abda8dee0
 DIST colorama-0.4.3.github.tar.gz 107251 BLAKE2B e09e92171b6ea4b3db4801feaf794e9aeb4f2b3e57079907911cbb909167b192eb857f0b404fa45673bee3bc02c122326bd05091846755d7dbfd990a74c60a24 SHA512 ab41a2f95fe75de0b280c174c6166b86645e5cc675dcedf784fe15170aae630e831370527c9490342b77c7d088a023a48428a519b52ad1c70be58904742a94c8
diff --git a/dev-python/colorama/colorama-0.3.9-r1.ebuild b/dev-python/colorama/colorama-0.3.9-r1.ebuild
deleted file mode 100644 (file)
index 2be8685..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7}} )
-
-inherit distutils-r1
-
-DESCRIPTION="ANSI escape character sequences for colored terminal text & cursor positioning"
-HOMEPAGE="
-       https://pypi.org/project/colorama/
-       https://github.com/tartley/colorama
-"
-# https://github.com/tartley/colorama/pull/183
-SRC_URI="https://github.com/tartley/${PN}/archive/${PV}.tar.gz -> ${P}.github.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-python_install_all() {
-       distutils-r1_python_install_all
-
-       if use examples; then
-               docinto examples
-               dodoc -r demos/.
-               docompress -x /usr/share/doc/${PF}/examples
-       fi
-}
-
-python_test() {
-       # Some tests require stdout to be a TTY
-       # https://github.com/tartley/colorama/issues/169
-       script -eqc "pytest -vv -s" /dev/null \
-               || die "tests failed with ${EPYTHON}"
-}