app-emulation/vice: Fix format-security Bug #560838
authorTupone Alfredo <tupone@gentoo.org>
Mon, 19 Oct 2015 15:35:39 +0000 (17:35 +0200)
committerTupone Alfredo <tupone@gentoo.org>
Mon, 19 Oct 2015 15:36:16 +0000 (17:36 +0200)
Package-Manager: portage-2.2.20.1

app-emulation/vice/files/vice-2.4.20-format.patch [new file with mode: 0644]
app-emulation/vice/vice-2.4.20.ebuild

diff --git a/app-emulation/vice/files/vice-2.4.20-format.patch b/app-emulation/vice/files/vice-2.4.20-format.patch
new file mode 100644 (file)
index 0000000..1c782fd
--- /dev/null
@@ -0,0 +1,20 @@
+--- src/main.c.old     2015-10-19 17:25:07.549164652 +0200
++++ src/main.c 2015-10-19 17:25:33.106694706 +0200
+@@ -227,7 +227,7 @@
+     for (i = 0; core_team[i].name; i++) {\r
+         n += strlen(core_team[i].name);\r
+         if (n > 74) {\r
+-            log_message(LOG_DEFAULT, tmp);\r
++            log_message(LOG_DEFAULT, "%s", tmp);\r
+             n = 0; *tmp = 0;\r
+         }\r
+         strcat(tmp, core_team[i].name);\r
+@@ -235,7 +235,7 @@
+             strcat(tmp, ", ");\r
+         } else {\r
+             strcat(tmp, ".");\r
+-            log_message(LOG_DEFAULT, tmp);\r
++            log_message(LOG_DEFAULT, "%s", tmp);\r
+         }\r
+     }\r
+     lib_free(tmp);\r
index 7bf597689693510a859fa6c853b0d85119d5d428..1ee7dc6d33ddebded9f1ba226673817002d2a45a 100644 (file)
@@ -88,6 +88,7 @@ DEPEND="${RDEPEND}
 src_prepare() {
        epatch \
                "${FILESDIR}"/${P}-autotools.patch \
+               "${FILESDIR}"/${P}-format.patch \
                "${FILESDIR}"/${P}-xf86extensions.patch
        sed -i \
                -e 's/building//' \