net-libs/qxmpp: update the 9999 ebuild
author0xd34df00d <0xd34df00d@gmail.com>
Tue, 10 Mar 2020 19:29:16 +0000 (15:29 -0400)
committerAndreas Sturmlechner <asturm@gentoo.org>
Tue, 10 Mar 2020 20:44:47 +0000 (21:44 +0100)
* EAPI 7
* `cmake` eclass instead of `cmake-utils`
* minor fixes to mirror the ones for the versioned ebuilds

Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Georg Rudoy <0xd34df00d@gmail.com>
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
net-libs/qxmpp/qxmpp-9999.ebuild

index b1973ffc3cced35436de717862d4b29e38d8df2a..453364d6055c1d6176be681471771d91a0d9271b 100644 (file)
@@ -1,14 +1,13 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-EGIT_REPO_URI="https://github.com/qxmpp-project/qxmpp"
-
-inherit git-r3 cmake-utils
+inherit git-r3 cmake
 
 DESCRIPTION="A cross-platform C++ XMPP client library based on the Qt framework"
 HOMEPAGE="https://github.com/qxmpp-project/qxmpp/"
+EGIT_REPO_URI="https://github.com/qxmpp-project/qxmpp"
 
 LICENSE="LGPL-2.1"
 SLOT="0"
@@ -26,17 +25,22 @@ RDEPEND="
        vpx? ( media-libs/libvpx:= )
 "
 DEPEND="${RDEPEND}
-       dev-util/cmake
        test? ( dev-qt/qttest:5 )
+"
+BDEPEND="
        doc? ( app-doc/doxygen )
 "
 
 src_prepare() {
        # requires network connection, bug #623708
-       sed -e "/qxmppiceconnection/d" \
-               -i tests/CMakeLists.txt || die "failed to drop single test"
-
-       cmake-utils_src_prepare
+       sed \
+               -e "/qxmppiceconnection/d" \
+               -e "/qxmppserver/d" \
+               -e "/qxmpptransfermanager/d" \
+               -i tests/CMakeLists.txt \
+               || die "failed to drop certain network tests"
+
+       cmake_src_prepare
 }
 
 src_configure() {
@@ -44,20 +48,12 @@ src_configure() {
                -DBUILD_DOCUMENTATION=$(usex doc)
                -DBUILD_EXAMPLES=OFF
                -DBUILD_TESTS=$(usex test)
+               -DBUILD_INTERNAL_TESTS=$(usex test)
                -DWITH_OPUS=$(usex opus)
                -DWITH_SPEEX=$(usex speex)
                -DWITH_THEORA=$(usex theora)
                -DWITH_VPX=$(usex vpx)
        )
 
-       cmake-utils_src_configure
-}
-
-src_install() {
-       cmake-utils_src_install
-
-       if use doc; then
-               # Use proper path for documentation
-               mv "${ED}"/usr/share/doc/${PN} "${ED}"/usr/share/doc/${PF} || die "doc mv failed"
-       fi
+       cmake_src_configure
 }