dev-python/flask-admin: Version bump (#652606)
authorPacho Ramos <pacho@gentoo.org>
Sun, 24 Jun 2018 11:23:33 +0000 (13:23 +0200)
committerPacho Ramos <pacho@gentoo.org>
Sun, 24 Jun 2018 11:30:57 +0000 (13:30 +0200)
Package-Manager: Portage-2.3.40, Repoman-2.3.9

dev-python/flask-admin/Manifest
dev-python/flask-admin/flask-admin-1.5.1.ebuild [new file with mode: 0644]

index b38f9f32356bb5d45066fbe1383525a7ea4614a5..1659774cf656a73ed0e9a9c971237a30228bbd53 100644 (file)
@@ -1,2 +1,3 @@
 DIST Flask-Admin-1.0.6.tar.gz 235842 BLAKE2B d0c2d48076d8c5d6f5df4b779128d1b9ecf00d8a6ef01df1d39a75212dc99f08a4ba7d03a95c8f39c4b3442ae4651d7185bf3faf528804f78f46277dd18dc3e2 SHA512 a30e2678a063d45d55ccf41cfec07fd16973cc8c770b1e7f16d11b9aba693049b1d9d4cff81d8ae8f2548d019f977f0906728e98d23d229d76bf135a079abc8f
 DIST Flask-Admin-1.5.0.tar.gz 1598074 BLAKE2B a7ca1fab32621cacfcf691f779e88e134369be82f1904db02f72cd51fbbdfecb22b9da06800a9cfae99336ed2807914a6420248c43775c9ec37d65ce242ce17c SHA512 dbf5b97f27228eb000fd1298f4da8d4824196856e4ba9e2d8cbae6e562794ec2d1a998b382efaa84ec4fd7a74ae589a739c52e117efebfb171f19bc16e7350e7
+DIST Flask-Admin-1.5.1.tar.gz 1587527 BLAKE2B e734284d3adb7380b71df3718910977c49f76c7e561991c969b8e85952cd3963ede0e1e039c8dcb7c512c00851f1968a9c6e011ad1a064dd8fe4d00390581c31 SHA512 00e31f126048321114e422fda4a0ec84b5caa1a0c03afa17fc6a7078a3f99f843c2688b07462bae283533d52a575935dbab2ce6b731b1d1c3a1e93f315e37de3
diff --git a/dev-python/flask-admin/flask-admin-1.5.1.ebuild b/dev-python/flask-admin/flask-admin-1.5.1.ebuild
new file mode 100644 (file)
index 0000000..2d35f4e
--- /dev/null
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+#RESTRICT="test" # we're still missing some of the dependencies
+
+MY_PN="Flask-Admin"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple and extensible admin interface framework for Flask"
+HOMEPAGE="https://pypi.org/project/Flask-Admin/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND="
+       >=dev-python/flask-0.7[${PYTHON_USEDEP}]
+       dev-python/wtforms[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/nose[${PYTHON_USEDEP}]
+               dev-python/flask-wtf[${PYTHON_USEDEP}]
+               dev-python/peewee[${PYTHON_USEDEP}]
+               dev-python/wtf-peewee[${PYTHON_USEDEP}]
+               dev-python/flask-pymongo[${PYTHON_USEDEP}]
+               dev-python/flask-mongoengine[${PYTHON_USEDEP}]
+               dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
+               dev-python/flask-babelex[${PYTHON_USEDEP}]
+               sci-libs/Shapely[${PYTHON_USEDEP}]
+               dev-python/geoalchemy2[${PYTHON_USEDEP}]
+               >=dev-python/pillow-2.9[${PYTHON_USEDEP},jpeg(+)]
+       )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+       sed \
+               -e 's:find_packages():find_packages(exclude=["*.examples", "*.examples.*", "examples.*", "examples"]):g' \
+               -i setup.py || die
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       nosetests || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+       use examples && dodoc -r examples
+       distutils-r1_python_install_all
+}