dev-ruby/rake: add ruby22
authorHans de Graaff <graaff@gentoo.org>
Wed, 16 Aug 2017 18:04:19 +0000 (20:04 +0200)
committerHans de Graaff <graaff@gentoo.org>
Wed, 16 Aug 2017 18:04:19 +0000 (20:04 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.2

dev-ruby/rake/rake-0.9.6-r1.ebuild

index 4d3fa36e44b8aadee3b0d97611730e42507c94b4..a5f937717f03a3f164eb80391a9e0d44b6f19d35 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
-USE_RUBY="ruby20 ruby21"
+USE_RUBY="ruby21 ruby22"
 
 RUBY_FAKEGEM_TASK_DOC=""
 RUBY_FAKEGEM_EXTRADOC="CHANGES README.rdoc TODO"
@@ -45,7 +45,7 @@ all_ruby_compile() {
 }
 
 each_ruby_test() {
-       ${RUBY} -S testrb test/test_*.rb || die
+       ${RUBY} -S testrb-2 test/test_*.rb || die
 }
 
 all_ruby_install() {