gnome-extra/gnome-system-monitor: bump to 3.32.1
authorMart Raudsepp <leio@gentoo.org>
Sun, 13 Oct 2019 14:45:20 +0000 (17:45 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sun, 13 Oct 2019 16:26:04 +0000 (19:26 +0300)
Package-Manager: Portage-2.3.69, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
gnome-extra/gnome-system-monitor/Manifest
gnome-extra/gnome-system-monitor/gnome-system-monitor-3.32.1.ebuild [new file with mode: 0644]

index 18f781a7a4d805fa3e34b767891339eccecdd233..1cf21f5cc9e1790ad88a24b2cf14689eeb36e985 100644 (file)
@@ -1 +1,2 @@
 DIST gnome-system-monitor-3.30.0.tar.xz 762004 BLAKE2B cf0ef6dde12a34f537e632dca6b45fc16ab49e92aaf49d2e945dded25b5cfbd855506368b82a0f840808760ce563f54fd8683f5a35652a5e10cdb4972ea61864 SHA512 c33dc510b15019de745a88d3eef12b5a2b19048bda22878988f22c4482f6a26ab20f5913f3104f2cb1b9566f7148a08b53d4e548f71345363273c51840fa2c8a
+DIST gnome-system-monitor-3.32.1.tar.xz 676936 BLAKE2B 815c677f637919966868b454b47f9633f130155573f7895e0c70025a59978818051bf8d087761d15416ccb0470c7341365dd95fdeabcdd0711802f828eddfa37 SHA512 badfb98e4508096336bba4be79ce359cf4363649e97c1da534ed96a04de4bc57e12b84ed75bfa9086e00b61b6558ee4af25eee14f0d2636d3ee0b62956122cbd
diff --git a/gnome-extra/gnome-system-monitor/gnome-system-monitor-3.32.1.ebuild b/gnome-extra/gnome-system-monitor/gnome-system-monitor-3.32.1.ebuild
new file mode 100644 (file)
index 0000000..9d90af4
--- /dev/null
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="The Gnome System Monitor"
+HOMEPAGE="https://help.gnome.org/users/gnome-system-monitor/stable/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="systemd X"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+       >=dev-cpp/glibmm-2.46:2
+       >=dev-libs/glib-2.56.0:2
+       >=x11-libs/gtk+-3.22:3[X(+)]
+       >=dev-cpp/gtkmm-3.3.18:3.0
+       >=gnome-base/libgtop-2.37.2:2=
+       >=gnome-base/librsvg-2.35:2
+       >=dev-libs/libxml2-2.0:2
+       X? ( >=x11-libs/libwnck-2.91.0:3 )
+       systemd? ( >=sys-apps/systemd-44:0= )
+"
+# eautoreconf requires gnome-base/gnome-common
+DEPEND="${RDEPEND}"
+BDEPEND="
+       dev-util/glib-utils
+       dev-util/itstool
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+       >=sys-auth/polkit-0.114
+" # polkit needed at buildtime for ITS rules of policy files, first available in 0.114
+
+src_configure() {
+       local emesonargs=(
+               $(meson_use X wnck)
+               $(meson_use systemd)
+       )
+       meson_src_configure
+}
+
+pkg_postinst() {
+       xdg_pkg_postinst
+       gnome2_schemas_update
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+       gnome2_schemas_update
+}