dev-python/click: add python 3.7 support
authorVirgil Dupras <vdupras@gentoo.org>
Tue, 21 Aug 2018 02:01:47 +0000 (22:01 -0400)
committerVirgil Dupras <vdupras@gentoo.org>
Tue, 21 Aug 2018 02:09:56 +0000 (22:09 -0400)
Package-Manager: Portage-2.3.47, Repoman-2.3.10

dev-python/click/click-6.7-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/click/click-6.7-r1.ebuild b/dev-python/click/click-6.7-r1.ebuild
new file mode 100644 (file)
index 0000000..ebdcd6b
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package for creating beautiful command line interfaces"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="http://click.pocoo.org/ https://pypi.org/project/click/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc examples test"
+
+REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+       # From upstream, can be removed in next release.
+       "${FILESDIR}/${PN}-6.7-fix-tests.patch"
+)
+
+pkg_setup() {
+       use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
+}
+
+python_prepare_all() {
+       # Prevent un-needed d'loading
+       sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/conf.py || die
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+       use doc && emake -C docs html
+}
+
+python_test() {
+       emake test
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( docs/_build/html/. )
+       use examples && dodoc -r examples
+       distutils-r1_python_install_all
+}