app-misc/mosquitto: bump to version 1.5.8
authorLucas Ramage <ramage.lucas@protonmail.com>
Sat, 13 Apr 2019 02:10:48 +0000 (22:10 -0400)
committerMichał Górny <mgorny@gentoo.org>
Thu, 25 Apr 2019 14:34:35 +0000 (16:34 +0200)
Package-Manager: Portage-2.3.62, Repoman-2.3.11
Signed-off-by: Lucas Ramage <ramage.lucas@protonmail.com>
Closes: https://github.com/gentoo/gentoo/pull/11689
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-misc/mosquitto/Manifest
app-misc/mosquitto/mosquitto-1.5.8.ebuild [new file with mode: 0644]

index da71fd286d04441580f97d05ba1857ea18b5fb27..f959bb3ee21652f59f39ac7c82695a6a8f70c311 100644 (file)
@@ -1 +1,2 @@
 DIST mosquitto-1.5.6.tar.gz 439402 BLAKE2B 7d887d7d2e02d9891613d441c76705c40744cd8c7acae330648e5a00560b4ba1fbc28b92ac84bf85d423c84de875c5309f364d04fca72516ab2276fe42512b0c SHA512 99bd935f93ae25f0c7992870780cce4748b35ffd58fd0d39e20ee69f34c28d3eac289cf0c7dec078dbdced3bda12da4569d4b5e84ebdaa5514640f331ca3238b
+DIST mosquitto-1.5.8.tar.gz 442834 BLAKE2B be5a7c2e7d28da0101fdfac9e5b0d7499abb71b464df3da11637c141947c75631e9c8952b219d20d598a156d0f8d5e86151c65ee4b55443dcef9c30eff49e3b3 SHA512 5cf2ae59077878be2784cc83fefe00fa3ff904646711545be519fc48557319c56dc7c15682fffc0dc42c530cdf59f550f25da9eec50a1a7deb222aa11bb669d3
diff --git a/app-misc/mosquitto/mosquitto-1.5.8.ebuild b/app-misc/mosquitto/mosquitto-1.5.8.ebuild
new file mode 100644 (file)
index 0000000..739d887
--- /dev/null
@@ -0,0 +1,101 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-any-r1 systemd toolchain-funcs user
+
+DESCRIPTION="An Open Source MQTT v3 Broker"
+HOMEPAGE="https://mosquitto.org/"
+SRC_URI="https://mosquitto.org/files/source/${P}.tar.gz"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="bridge examples +persistence +srv ssl tcpd test websockets"
+
+REQUIRED_USE="test? ( bridge )"
+
+RDEPEND="srv? ( net-dns/c-ares )
+       ssl? ( dev-libs/openssl:0= )
+       tcpd? ( sys-apps/tcp-wrappers )"
+
+DEPEND="${PYTHON_DEPS}
+       ${RDEPEND}
+       websockets? ( net-libs/libwebsockets )"
+
+_emake() {
+       LIBDIR=$(get_libdir)
+       emake \
+               CC="$(tc-getCC)" \
+               LIB_SUFFIX="${LIBDIR:3}" \
+               WITH_BRIDGE="$(usex bridge)" \
+               WITH_PERSISTENCE="$(usex persistence)" \
+               WITH_SRV="$(usex srv)" \
+               WITH_TLS="$(usex ssl)" \
+               WITH_WEBSOCKETS="$(usex websockets)" \
+               WITH_WRAP="$(usex tcpd)" \
+               "$@"
+}
+
+pkg_setup() {
+       enewgroup mosquitto
+       enewuser mosquitto -1 -1 -1 mosquitto
+}
+
+src_prepare() {
+       default
+       if use persistence; then
+               sed -i -e "/^#autosave_interval/s|^#||" \
+                       -e "s|^#persistence false$|persistence true|" \
+                       -e "/^#persistence_file/s|^#||" \
+                       -e "s|#persistence_location|persistence_location /var/lib/mosquitto/|" \
+                       mosquitto.conf || die
+       fi
+
+       # Remove prestripping
+       sed -i -e 's/-s --strip-program=${CROSS_COMPILE}${STRIP}//'\
+               client/Makefile lib/cpp/Makefile src/Makefile lib/Makefile || die
+
+       python_setup
+       rm test/{broker,lib}/ptest.py || die
+       python_fix_shebang test
+}
+
+src_compile() {
+       _emake
+}
+
+src_test() {
+       _emake test
+}
+
+src_install() {
+       _emake DESTDIR="${D}" prefix=/usr install
+       keepdir /var/lib/mosquitto
+       fowners mosquitto:mosquitto /var/lib/mosquitto
+       dodoc readme.md CONTRIBUTING.md ChangeLog.txt
+       doinitd "${FILESDIR}"/mosquitto
+       insinto /etc/mosquitto
+       doins mosquitto.conf
+       systemd_dounit "${FILESDIR}/mosquitto.service"
+
+       if use examples; then
+               docompress -x "/usr/share/doc/${PF}/examples"
+               dodoc -r examples
+       fi
+}
+
+pkg_postinst() {
+       if [[ -z "${REPLACING_VERSIONS}" ]]; then
+               elog "The Python module has been moved out of mosquitto."
+               elog "See https://mosquitto.org/documentation/python/"
+       else
+               elog "To start the mosquitto daemon at boot, add it to the default runlevel with:"
+               elog ""
+               elog "    rc-update add mosquitto default"
+               elog "or"
+               elog "    systemctl enable mosquitto"
+       fi
+}