app-text/pytextile: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sat, 7 Mar 2020 15:01:54 +0000 (16:01 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 7 Mar 2020 15:01:54 +0000 (16:01 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-text/pytextile/Manifest
app-text/pytextile/pytextile-2.3.3.ebuild [deleted file]

index 781743a9264a9f8db26b4665d7308717dd2639ec..16cdcb6a80376e0ca098c2878d68c731a1e963e5 100644 (file)
@@ -1,2 +1 @@
-DIST pytextile-2.3.3.tar.gz 42277 BLAKE2B a6e6e1d96695f3ada03f5da9bd8bd19b99da345d83c62b1d4f2e765303dfbbbee072da4611f1b29b46d28ed334373c809117940ff0c1238dea3b12fb9076656c SHA512 980c872bfdc056753fa5b344cbc828dbdc9ddfc2656f3cfb5c15b3351cfd9e4016f57af14b60af2f2764e556865301d7923a8f0687c5857fc2201bf10f56ab60
 DIST pytextile-3.0.3.tar.gz 48560 BLAKE2B f8d3077e2b8e4de7157dcd9ed17f7889301946c2d3034dbbb0171b4930bd7268c65ce1f950552db2b783aa48acae639d5f4ccfcbca96807562b4a6377c3dd220 SHA512 142fe77c8858b0444428f9ca0f24d1a054a1566f85f00fd5cf860bb705a19666249cd03420d258d5acfc9f45052dd25e52767492a60a10d986d86b711b54612f
diff --git a/app-text/pytextile/pytextile-2.3.3.ebuild b/app-text/pytextile/pytextile-2.3.3.ebuild
deleted file mode 100644 (file)
index 69515f3..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-MY_PN="python-textile"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A Python port of Textile, A humane web text generator"
-HOMEPAGE="https://github.com/textile/python-textile"
-SRC_URI="https://github.com/textile/python-textile/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       dev-python/pytest-runner[${PYTHON_USEDEP}]
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-RDEPEND="
-       dev-python/regex[${PYTHON_USEDEP}]
-       "
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
-       # This resolves a nasty race condition, courtesy of Arfrever
-       sed -e 's:with-id = 1::' -i setup.cfg || die
-       # remove useless --cov arg injection
-       rm pytest.ini || die
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       py.test || die "Testsuite failed under ${EPYTHON}"
-}