gui-libs/tepl: Bump to 4.2.1
authorPacho Ramos <pacho@gentoo.org>
Sun, 15 Dec 2019 16:45:14 +0000 (17:45 +0100)
committerPacho Ramos <pacho@gentoo.org>
Sun, 15 Dec 2019 16:48:17 +0000 (17:48 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.19
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
gui-libs/tepl/Manifest
gui-libs/tepl/tepl-4.2.1.ebuild [new file with mode: 0644]

index c1eef7a0038623049564ae8f2a61d66db4bb2ca0..d502234bc26af4c968188f5b60df9dbd6a8abf24 100644 (file)
@@ -1 +1,2 @@
 DIST tepl-4.2.0.tar.xz 456540 BLAKE2B 8861d2cdcddcb5b9e5aa58798835c0969dd12ce6c5ada69b5b97224f215bfdbf8ee0a7173d5c7cb2cc11894988351ce4df7a81e91e7b7036a48cc89e2cb9dd62 SHA512 32f69c6f0942a82e6b7f94eba776d55dce2af1c8e4c7abadf6af38a0a5abb0a94f0c426d5ec727b8eb478406ba113728b771597c2c84e508b8ccb113a74eab3d
+DIST tepl-4.2.1.tar.xz 464120 BLAKE2B 74146cdf837923ab1a8e843e189bd83b2c7d7ae9cbf03ce4f3dbbbbfee1f47dffcda537ad8133cdf1b4efd747f0ee60092ddab029a67282b71fdc52d51564dc4 SHA512 c1b848cf1d336efdc2971e16060baf721e9019e6e6827bd755235c9dd37ae47803343e51888d9dd5817b6127bb1ba05a19d4a1be0caab9d2de125bc0cd8175a7
diff --git a/gui-libs/tepl/tepl-4.2.1.ebuild b/gui-libs/tepl/tepl-4.2.1.ebuild
new file mode 100644 (file)
index 0000000..61989b5
--- /dev/null
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2 virtualx
+
+DESCRIPTION="GtkSourceView-based text editors and IDE helper library"
+HOMEPAGE="https://wiki.gnome.org/Projects/Gtef"
+
+LICENSE="LGPL-2.1+"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection"
+
+RDEPEND="
+       >=dev-libs/glib-2.52:2
+       >=x11-libs/gtk+-3.22:3[introspection?]
+       >=x11-libs/gtksourceview-4.0:4[introspection?]
+       >=gui-libs/amtk-5.0:5[introspection?]
+       >=dev-libs/libxml2-2.5:2
+       app-i18n/uchardet
+       introspection? ( >=dev-libs/gobject-introspection-1.42:= )
+"
+DEPEND="${DEPEND}
+       >=sys-devel/gettext-0.19.4
+       dev-util/glib-utils
+       >=dev-util/gtk-doc-am-1.25
+       virtual/pkgconfig
+"
+
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+       # requires running gvfs-metadata
+       sed -e 's:\(g_test_add_func.*/file/load_save_metadata_sync.*\):/*\1*/:' \
+               -e 's:\(g_test_add_func.*/file/load_save_metadata_async.*\):/*\1*/:' \
+               -e 's:\(g_test_add_func.*/file/set_without_load.*\):/*\1*/:' \
+               -i testsuite/test-file-metadata.c || die
+
+       gnome2_src_prepare
+}
+
+src_configure() {
+       # valgrind checks not ran by default and require suppression files not in locations where they'd be installed by other packages
+       gnome2_src_configure \
+               --enable-gvfs-metadata \
+               --disable-valgrind \
+               $(use_enable introspection)
+}
+
+src_test() {
+       virtx emake check
+}