projects
/
gentoo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
1fb6594
)
dev-libs/libcharon: use current python version
author
Michael Perlov
<perlovka@gmail.com>
Sat, 28 Sep 2019 23:36:32 +0000
(
02:36
+0300)
committer
Joonas Niilola
<juippis@gentoo.org>
Wed, 16 Oct 2019 05:22:00 +0000
(08:22 +0300)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Michael Perlov <perlovka@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/13073
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-libs/libcharon/libcharon-4.3.0.ebuild
patch
|
blob
|
history
diff --git
a/dev-libs/libcharon/libcharon-4.3.0.ebuild
b/dev-libs/libcharon/libcharon-4.3.0.ebuild
index b8424b88bd25d61ccaa5d6188193c007f6eda8f0..19d4856e4353bfe96423e80930147316db16ff78 100644
(file)
--- a/
dev-libs/libcharon/libcharon-4.3.0.ebuild
+++ b/
dev-libs/libcharon/libcharon-4.3.0.ebuild
@@
-21,3
+21,10
@@
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}"
S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ # Use current python version, not the latest installed
+ sed -i "s/find_package(Python3 3.4 REQUIRED/find_package(Python3 ${EPYTHON##python} EXACT REQUIRED/g" CMakeLists.txt || die
+
+ cmake-utils_src_prepare
+}