media-sound/gmpc: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Thu, 12 Dec 2019 16:02:56 +0000 (17:02 +0100)
committerDavid Seifert <soap@gentoo.org>
Thu, 12 Dec 2019 16:02:56 +0000 (17:02 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
media-sound/gmpc/files/gmpc-11.8.16-AM_CONFIG_HEADER.patch [new file with mode: 0644]
media-sound/gmpc/gmpc-11.8.16-r1.ebuild

diff --git a/media-sound/gmpc/files/gmpc-11.8.16-AM_CONFIG_HEADER.patch b/media-sound/gmpc/files/gmpc-11.8.16-AM_CONFIG_HEADER.patch
new file mode 100644 (file)
index 0000000..3368917
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -14,7 +14,7 @@
+-AM_CONFIG_HEADER([config.h])
++AC_CONFIG_HEADERS([config.h])
+ AC_CONFIG_MACRO_DIR([m4])
+ AM_INIT_AUTOMAKE
index 9629d477e07ae3b2ac7c4b055ecf02eae99faeb4..0fcbc8fbc67fc6ea91a8699909acce712788c001 100644 (file)
@@ -1,10 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
-VALA_MIN_API_VERSION=0.12
+EAPI=7
 
-inherit autotools eutils gnome2-utils vala
+inherit autotools vala xdg
 
 DESCRIPTION="A GTK+2 client for the Music Player Daemon"
 HOMEPAGE="http://gmpc.wikia.com/wiki/Gnome_Music_Player_Client"
@@ -13,32 +12,38 @@ SRC_URI="http://download.sarine.nl/Programs/gmpc/11.8/${P}.tar.gz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="amd64 ppc x86"
-IUSE="nls xspf +unique"
-
-RDEPEND="dev-db/sqlite:3
-       >=dev-libs/glib-2.16:2
-       dev-libs/libxml2:2
-       >=media-libs/libmpd-11.8
-       net-libs/libsoup:2.4
-       >=x11-libs/gtk+-2.18:2
+IUSE="nls +unique xspf"
+
+RDEPEND="
+       dev-db/sqlite:3=
+       dev-libs/glib:2
+       dev-libs/libxml2:2=
+       media-libs/libmpd:=
+       net-libs/libsoup:2.4=
+       x11-libs/gtk+:2
        x11-libs/libX11
        x11-themes/hicolor-icon-theme
-       unique? ( dev-libs/libunique:1 )
-       xspf? ( >=media-libs/libxspf-1.2 )"
-DEPEND="${RDEPEND}
+       unique? ( dev-libs/libunique:1= )
+       xspf? ( media-libs/libxspf:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="
        $(vala_depend)
        app-text/gnome-doc-utils
-       >=dev-util/gob-2.0.17
+       dev-util/gob
        virtual/pkgconfig
-       nls? ( dev-util/intltool
-               sys-devel/gettext )"
+       nls? (
+               dev-util/intltool
+               sys-devel/gettext
+       )"
 
-DOCS=( AUTHORS README )
+PATCHES=(
+       "${FILESDIR}"/${P}-underlinking.patch
+       "${FILESDIR}"/${P}-icons.patch
+       "${FILESDIR}"/${P}-AM_CONFIG_HEADER.patch
+)
 
 src_prepare() {
-       epatch "${FILESDIR}"/${P}-underlinking.patch \
-               "${FILESDIR}"/${P}-icons.patch
-       sed -i -e "s:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:" configure.ac || die
+       xdg_src_prepare
        eautoreconf
        vala_src_prepare
 }
@@ -53,7 +58,3 @@ src_configure() {
                $(use_enable unique) \
                $(use_enable xspf libxspf)
 }
-
-pkg_preinst() { gnome2_icon_savelist; }
-pkg_postinst() { gnome2_icon_cache_update; }
-pkg_postrm() { gnome2_icon_cache_update; }