dev-python/plumbum: initial import
authorAndrey Grozin <grozin@gentoo.org>
Fri, 4 Sep 2015 09:59:11 +0000 (15:59 +0600)
committerAndrey Grozin <grozin@gentoo.org>
Fri, 4 Sep 2015 09:59:11 +0000 (15:59 +0600)
Package-Manager: portage-2.2.20.1

dev-python/plumbum/Manifest [new file with mode: 0644]
dev-python/plumbum/metadata.xml [new file with mode: 0644]
dev-python/plumbum/plumbum-1.5.0.ebuild [new file with mode: 0644]

diff --git a/dev-python/plumbum/Manifest b/dev-python/plumbum/Manifest
new file mode 100644 (file)
index 0000000..9744c9b
--- /dev/null
@@ -0,0 +1 @@
+DIST plumbum-1.5.0.tar.gz 57390 SHA256 b759f9e3b6771dff3332f01bc0683d1a56218f44d97942dabd906a0cd1cfb756 SHA512 68c248cf6e40281bc97ef9ba69ff03b3e5b486f44d2a66674fd6073313bbce49abc729f8c99ec1988d9a8881f4c1ff8cf70ac238a38eabf9a3da76d452be525f WHIRLPOOL 9d9660a81546348f4a2c3910fa455b597429f9a23cd9c9a053bc2728e352e38bdb5d2b89f6f3a741e937522b7aabb7f5071f7d34efcdbe82d88e647854d1678d
diff --git a/dev-python/plumbum/metadata.xml b/dev-python/plumbum/metadata.xml
new file mode 100644 (file)
index 0000000..f43044e
--- /dev/null
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <herd>python</herd>
+  <maintainer>
+    <email>grozin@gentoo.org</email>
+    <name>Andrey Grozin</name>
+  </maintainer>
+  <longdescription>
+    A library for shell script-like programs in python,
+    attempting to mimic the shell syntax (shell combinators) where it makes sense,
+    while keeping it all Pythonic and cross-platform.
+  </longdescription>
+</pkgmetadata>
diff --git a/dev-python/plumbum/plumbum-1.5.0.ebuild b/dev-python/plumbum/plumbum-1.5.0.ebuild
new file mode 100644 (file)
index 0000000..4279cab
--- /dev/null
@@ -0,0 +1,15 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+inherit distutils-r1
+
+DESCRIPTION="A library for shell script-like programs in python"
+HOMEPAGE="http://plumbum.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""