Removing the old revision, using chmod / chown directly (sue me, fowners / fperms...
authorChristian Heim <phreak@gentoo.org>
Mon, 8 Jan 2007 20:57:15 +0000 (20:57 +0000)
committerChristian Heim <phreak@gentoo.org>
Mon, 8 Jan 2007 20:57:15 +0000 (20:57 +0000)
Package-Manager: portage-2.1.2_rc4-r6

net-wireless/ipw3945d/ChangeLog
net-wireless/ipw3945d/ipw3945d-1.7.22-r4.ebuild

index 587b9184a4ebe55fca3cacce1fc6764f030264f4..b3523cbb307dc413d0e69ef872aaf93c4b15c130 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for net-wireless/ipw3945d
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/ipw3945d/ChangeLog,v 1.11 2006/12/22 10:11:26 phreak Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/ipw3945d/ChangeLog,v 1.12 2007/01/08 20:57:15 phreak Exp $
+
+  08 Jan 2007; Christian Heim <phreak@gentoo.org>
+  -ipw3945d-1.7.22-r3.ebuild, ipw3945d-1.7.22-r4.ebuild:
+  Removing the old revision, using chmod / chown directly (sue me, fowners /
+  fperms won't work on files outside of ${D}).
 
   22 Dec 2006; Christian Heim <phreak@gentoo.org> files/ipw3945d-init.d:
   Fixing a bug within the init-script, using 'exit 1' isn't allowed (thanks to
index cae6ca997439576af7b8ba4c6464915c753e622f..311b2ccc176b3d1b66399e411da95d04dba0e7df 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/ipw3945d/ipw3945d-1.7.22-r4.ebuild,v 1.3 2006/12/18 00:33:31 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/ipw3945d/ipw3945d-1.7.22-r4.ebuild,v 1.4 2007/01/08 20:57:15 phreak Exp $
 
 inherit eutils
 
@@ -30,11 +30,11 @@ src_install() {
        use amd64 && dosbin x86_64/ipw3945d
 
        # Give the ipw3945d access to the binary
-       fowners ipw3945d:root /sbin/ipw3945d
-       fperms 04450 /sbin/ipw3945d
+       chown ipw3945d:root /sbin/ipw3945d
+       chmod 04450 /sbin/ipw3945d
 
        keepdir /var/run/ipw3945d
-       fowners ipw3945d:root /var/run/ipw3945d
+       chown ipw3945d:root /var/run/ipw3945d
 
        newconfd "${FILESDIR}/${PN}-conf.d" ${PN}
        newinitd "${FILESDIR}/${PN}-init.d" ${PN}
@@ -48,7 +48,9 @@ src_install() {
 pkg_postinst() {
        # Update the modules.d cache
        if [ -f "${ROOT}/etc/modules.d/${PN}" ] ; then
-               ${ROOT}/sbin/modules-update --force
+               ebegin "Executing /sbin/modules-update"
+               "${ROOT}"sbin/modules-update --force
+               eend $?
        fi
 
        echo
@@ -59,13 +61,13 @@ pkg_postinst() {
        # this, these hacks can go away.
 
        # Fix the permissions of /sbin/ipw3945d
-       ebegin "Fixing permissions of ${ROOT}/sbin/ipw3945d"
-       fperms 04450 ${ROOT}/sbin/ipw3945d
+       ebegin "Fixing permissions of ${ROOT}sbin/ipw3945d"
+       chmod 04450 "${ROOT}"sbin/ipw3945d
        eend $?
 
        # Fixing ownership of /var/run/ipw3945d
-       ebegin "Fixing ownership of ${ROOT}/var/run/ipw3945d"
-       fowners ipw3945d:root ${ROOT}/var/run/ipw3945d
+       ebegin "Fixing ownership of ${ROOT}var/run/ipw3945d"
+       chown ipw3945d:root "${ROOT}"var/run/ipw3945d
        eend $?
 
        echo