dev-python/python-neutronclient: 6.12.1 stable amd64/x86 with cleanup
authorMatthew Thode <prometheanfire@gentoo.org>
Wed, 18 Mar 2020 17:02:22 +0000 (12:02 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Wed, 18 Mar 2020 17:06:30 +0000 (12:06 -0500)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/python-neutronclient/Manifest
dev-python/python-neutronclient/metadata.xml
dev-python/python-neutronclient/python-neutronclient-6.12.0.ebuild [deleted file]
dev-python/python-neutronclient/python-neutronclient-6.12.1.ebuild

index 3ca613ff659c8c5ddca29562637ca82fcbf02e1c..d6cab159870471f2b73b205c9294db387e854279 100644 (file)
@@ -1,2 +1 @@
-DIST python-neutronclient-6.12.0.tar.gz 290025 BLAKE2B f863826a531708fda1b9ddb43f8bfd8f66fbba99ce3fe4afc1135d20fe4718dc7f11789c3e75cf52089690ce0286bf5339c9253d1e7e35916befb52ed905448a SHA512 c7e69e263b37aa14b59b08ecc12f13210e1bd6f10cde10d8b4d5b8b9f912d604e23ff41eed684baf09bb6dc278393a55ca87d6e41e0986235cd3366d321dd85f
 DIST python-neutronclient-6.12.1.tar.gz 290511 BLAKE2B 046de903c30539183c5650e3f666ba1f24c311d0a9848cbc7c79d64f0d35a0c380917453bf7c8251a1099fc13a15da2ecd5facacde26ec46d859510ba4203dff SHA512 cae17fbffb4f0e78aeff07e90a1d08e5f2aaa3221192be8bf66ad8ed108ee01b0307f7a9a862c685061c77ceb831a7eac4c8343a8b5a71d1380277cdddd90b07
index 295d065c537d8bc08d272ca6452148a90ff3e3c3..abb39171838badfeaab66dcf61c564db7bce01d5 100644 (file)
@@ -9,9 +9,6 @@
     <email>openstack@gentoo.org</email>
     <name>Openstack</name>
   </maintainer>
-  <longdescription lang="en">
-    CLI and python client library for OpenStack Neutron
-  </longdescription>
   <upstream>
     <remote-id type="pypi">python-neutronclient</remote-id>
     <remote-id type="launchpad">neutron</remote-id>
diff --git a/dev-python/python-neutronclient/python-neutronclient-6.12.0.ebuild b/dev-python/python-neutronclient/python-neutronclient-6.12.0.ebuild
deleted file mode 100644 (file)
index 735bdae..0000000
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="A client for the OpenStack Quantum API"
-HOMEPAGE="https://launchpad.net/neutron"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
-       !~dev-python/pbr-2.1.0"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       ${CDEPEND}
-       test? (
-               >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
-               >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
-               !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
-               >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
-               >=dev-python/mox3-0.20.0[${PYTHON_USEDEP}]
-               >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
-               >=dev-python/openstackdocstheme-1.17.0[${PYTHON_USEDEP}]
-               >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
-               >=dev-python/osprofiler-2.3.0[${PYTHON_USEDEP}]
-               >=dev-python/python-openstackclient-3.12.0[${PYTHON_USEDEP}]
-               >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
-               >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
-               >=dev-python/requests-mock-1.2.0[${PYTHON_USEDEP}]
-               >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
-               >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
-               >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
-       )"
-
-RDEPEND="
-       ${CDEPEND}
-       >=dev-python/cliff-2.8.0[${PYTHON_USEDEP}]
-       !~dev-python/cliff-2.9.0[${PYTHON_USEDEP}]
-       >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
-       >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
-       >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
-       >=dev-python/osc-lib-1.8.0[${PYTHON_USEDEP}]
-       >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
-       >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
-       >=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
-       !~dev-python/oslo-serialization-2.19.1[${PYTHON_USEDEP}]
-       >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
-       >=dev-python/os-client-config-1.28.0[${PYTHON_USEDEP}]
-       >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
-       >=dev-python/python-keystoneclient-3.8.0[${PYTHON_USEDEP}]
-       >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
-       >=dev-python/simplejson-3.5.1[${PYTHON_USEDEP}]
-       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
-       >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
-       !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
-       # built in...
-       sed -i '/^hacking/d' test-requirements.txt || die
-       sed -i '/^flake8-import-order/d' test-requirements.txt || die
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       testr init
-       testr run || die "tests failed under python2.7"
-       flake8 neutronclient/tests || die "run by flake8 over tests folder yielded error"
-}
-
-python_install() {
-       distutils-r1_python_install
-       #stupid stupid
-       local SITEDIR="${D}$(python_get_sitedir)" || die
-       cd "${SITEDIR}" || die
-       local egg=( python_neutronclient*.egg-info )
-       #[[ -f ${egg[0]} ]] || die "python_quantumclient*.egg-info not found"
-       ln -s "${egg[0]}" "${egg[0]/neutron/quantum}" || die
-       ln -s neutronclient quantumclient || die
-       ln -s neutron quantumclient/quantum || die
-}
index e6783c8e132e68628b5f734912410e555faa4bcc..735bdaeb4a7b0db58aad40136dedb7841a798d31 100644 (file)
@@ -12,7 +12,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 
 LICENSE="Apache-2.0"
 SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
 IUSE="test"
 RESTRICT="!test? ( test )"