dev-ml/ocaml-ctypes: Add missing lwt deps for tests
authorAlexis Ballier <aballier@gentoo.org>
Mon, 27 Feb 2017 09:44:37 +0000 (10:44 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 27 Feb 2017 09:44:37 +0000 (10:44 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-ml/ocaml-ctypes/ocaml-ctypes-0.11.3-r1.ebuild [new file with mode: 0644]

diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.11.3-r1.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.11.3-r1.ebuild
new file mode 100644 (file)
index 0000000..34b6fa3
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Library for binding to C libraries using pure OCaml"
+HOMEPAGE="https://github.com/ocamllabs/ocaml-ctypes"
+SRC_URI="https://github.com/ocamllabs/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+       >=dev-lang/ocaml-4.02:=[ocamlopt]
+       virtual/libffi
+"
+DEPEND="${RDEPEND}
+       test? ( dev-ml/ounit dev-ml/lwt )"
+
+src_compile() {
+       emake -j1
+}
+
+src_test() {
+       emake -j1 test
+}
+
+src_install() {
+       findlib_src_install
+       dodoc CHANGES.md README.md
+}