sys-apps/kmod: Removed old.
authorLars Wendler <polynomial-c@gentoo.org>
Mon, 27 Feb 2017 10:39:45 +0000 (11:39 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Mon, 27 Feb 2017 10:44:11 +0000 (11:44 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

sys-apps/kmod/Manifest
sys-apps/kmod/kmod-22.ebuild [deleted file]

index 6a76a44926c39dd5bbdf1e0ee12bc535d393186e..2d31df321c0316ebbc7c04e7641d09613b65ddcd 100644 (file)
@@ -1,3 +1,2 @@
-DIST kmod-22.tar.xz 449724 SHA256 ba3b1ddea33228b473189fcb05b809024a3b86e9a7cf37d420cae06beb749f82 SHA512 e021bacebb07ba4a178215ca1d1e091195fed1d289a76ec3ddb309182a90b6eab19d98eb1331772bc739f73ed6f540d92213b8088a573df13cd28ebd333a8876 WHIRLPOOL ed5b338698f250a0cb344da0789099a4fcdd098a1d64ed0f912fbb361ee91eaf13ceffec28e95757778a687ed8ed8acce16c0717000c598237e01abda256ca1c
 DIST kmod-23.tar.xz 450376 SHA256 d303d5519faec9d69e1132f6b37db2579db17a7fb5c1517da0115d03ba168155 SHA512 84b18d35117b33c48fd9b732a584a9f94caef553e371bd4e68953540f46fc6c7145c8c7163df898875437ad56e1a47e89be26531314299bce0026c46da9dd3c0 WHIRLPOOL 319fc1c4728e51ef97a4c999ddcf8dc38587028b239a8adf48750335548c3a8e099d3b6a4d1d7a9b3f80ac83609a109d3053dea10ad8b98c2d694494b7f09330
 DIST kmod-24.tar.xz 536864 SHA256 610b8d1df172acc39a4fdf1eaa47a57b04873c82f32152e7a62e29b6ff9cb397 SHA512 58c8da100418b6325de1595bceee4115cbdd7151d03a028c0b1f6d5d3e6611c667e27f3a0245d29781125581849fd1e854fa8d87b63c4b8fa3f196d0a97e1779 WHIRLPOOL f722a515967f8a8cf60e4a053f9227a848230d8b006ca9ba13160b2d5e9f1d4b5abb30f7d4c3c04287da58c7960dd36a5cf7d122036457990b93e0ed42e84195
diff --git a/sys-apps/kmod/kmod-22.ebuild b/sys-apps/kmod/kmod-22.ebuild
deleted file mode 100644 (file)
index 1fb1c76..0000000
+++ /dev/null
@@ -1,190 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4} )
-
-inherit bash-completion-r1 eutils multilib python-r1
-
-if [[ ${PV} == 9999* ]]; then
-       EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/kernel/${PN}/${PN}.git"
-       inherit autotools git-2
-else
-       SRC_URI="mirror://kernel/linux/utils/kernel/kmod/${P}.tar.xz"
-       KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
-       inherit libtool
-fi
-
-DESCRIPTION="library and tools for managing linux kernel modules"
-HOMEPAGE="https://git.kernel.org/?p=utils/kernel/kmod/kmod.git"
-
-LICENSE="LGPL-2"
-SLOT="0"
-IUSE="debug doc lzma python static-libs +tools zlib"
-
-# Upstream does not support running the test suite with custom configure flags.
-# I was also told that the test suite is intended for kmod developers.
-# So we have to restrict it.
-# See bug #408915.
-RESTRICT="test"
-
-# Block systemd below 217 for -static-nodes-indicate-that-creation-of-static-nodes-.patch
-RDEPEND="!sys-apps/module-init-tools
-       !sys-apps/modutils
-       !<sys-apps/openrc-0.13.8
-       !<sys-apps/systemd-216-r3
-       lzma? ( >=app-arch/xz-utils-5.0.4-r1 )
-       python? ( ${PYTHON_DEPS} )
-       zlib? ( >=sys-libs/zlib-1.2.6 )" #427130
-DEPEND="${RDEPEND}
-       doc? ( dev-util/gtk-doc )
-       lzma? ( virtual/pkgconfig )
-       python? (
-               dev-python/cython[${PYTHON_USEDEP}]
-               virtual/pkgconfig
-               )
-       zlib? ( virtual/pkgconfig )"
-if [[ ${PV} == 9999* ]]; then
-       DEPEND="${DEPEND}
-               dev-libs/libxslt"
-fi
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-DOCS="NEWS README TODO"
-
-src_prepare() {
-       if [ ! -e configure ]; then
-               if use doc; then
-                       gtkdocize --copy --docdir libkmod/docs || die
-               else
-                       touch libkmod/docs/gtk-doc.make
-               fi
-               eautoreconf
-       else
-               elibtoolize
-       fi
-
-       # Restore possibility of running --enable-static wrt #472608
-       sed -i \
-               -e '/--enable-static is not supported by kmod/s:as_fn_error:echo:' \
-               configure || die
-}
-
-src_configure() {
-       local myeconfargs=(
-               --bindir="${EPREFIX}/bin"
-               --with-rootlibdir="${EPREFIX}/$(get_libdir)"
-               --enable-shared
-               $(use_enable static-libs static)
-               $(use_enable tools)
-               $(use_enable debug)
-               $(use_enable doc gtk-doc)
-               $(use_with lzma xz)
-               $(use_with zlib)
-               --with-bashcompletiondir="$(get_bashcompdir)"
-       )
-
-       local ECONF_SOURCE="${S}"
-
-       kmod_configure() {
-               mkdir -p "${BUILD_DIR}" || die
-               run_in_build_dir econf "${myeconfargs[@]}" "$@"
-       }
-
-       BUILD_DIR="${WORKDIR}/build"
-       kmod_configure --disable-python
-
-       if use python; then
-               python_foreach_impl kmod_configure --enable-python
-       fi
-}
-
-src_compile() {
-       emake -C "${BUILD_DIR}"
-
-       if use python; then
-               local native_builddir=${BUILD_DIR}
-
-               python_compile() {
-                       emake -C "${BUILD_DIR}" -f Makefile -f - python \
-                               VPATH="${native_builddir}:${S}" \
-                               native_builddir="${native_builddir}" \
-                               libkmod_python_kmod_{kmod,list,module,_util}_la_LIBADD='$(PYTHON_LIBS) $(native_builddir)/libkmod/libkmod.la' \
-                               <<< 'python: $(pkgpyexec_LTLIBRARIES)'
-               }
-
-               python_foreach_impl python_compile
-       fi
-}
-
-src_install() {
-       emake -C "${BUILD_DIR}" DESTDIR="${D}" install
-       einstalldocs
-
-       if use python; then
-               local native_builddir=${BUILD_DIR}
-
-               python_install() {
-                       emake -C "${BUILD_DIR}" DESTDIR="${D}" \
-                               VPATH="${native_builddir}:${S}" \
-                               install-pkgpyexecLTLIBRARIES \
-                               install-dist_pkgpyexecPYTHON
-               }
-
-               python_foreach_impl python_install
-       fi
-
-       prune_libtool_files --modules
-
-       if use tools; then
-               local bincmd sbincmd
-               for sbincmd in depmod insmod lsmod modinfo modprobe rmmod; do
-                       dosym ../bin/kmod /sbin/${sbincmd}
-               done
-
-               # These are also usable as normal user
-               for bincmd in lsmod modinfo; do
-                       dosym kmod /bin/${bincmd}
-               done
-       fi
-
-       cat <<-EOF > "${T}"/usb-load-ehci-first.conf
-       softdep uhci_hcd pre: ehci_hcd
-       softdep ohci_hcd pre: ehci_hcd
-       EOF
-
-       insinto /lib/modprobe.d
-       doins "${T}"/usb-load-ehci-first.conf #260139
-
-       newinitd "${FILESDIR}"/kmod-static-nodes-r1 kmod-static-nodes
-}
-
-pkg_postinst() {
-       if [[ -L ${EROOT%/}/etc/runlevels/boot/static-nodes ]]; then
-               ewarn "Removing old conflicting static-nodes init script from the boot runlevel"
-               rm -f "${EROOT%/}"/etc/runlevels/boot/static-nodes
-       fi
-
-       # Add kmod to the runlevel automatically if this is the first install of this package.
-       if [[ -z ${REPLACING_VERSIONS} ]]; then
-               if [[ ! -d ${EROOT%/}/etc/runlevels/sysinit ]]; then
-                       mkdir -p "${EROOT%/}"/etc/runlevels/sysinit
-               fi
-               if [[ -x ${EROOT%/}/etc/init.d/kmod-static-nodes ]]; then
-                       ln -s /etc/init.d/kmod-static-nodes "${EROOT%/}"/etc/runlevels/sysinit/kmod-static-nodes
-               fi
-       fi
-
-       if [[ -e ${EROOT%/}/etc/runlevels/sysinit ]]; then
-               if [[ ! -e ${EROOT%/}/etc/runlevels/sysinit/kmod-static-nodes ]]; then
-                       ewarn
-                       ewarn "You need to add kmod-static-nodes to the sysinit runlevel for"
-                       ewarn "kernel modules to have required static nodes!"
-                       ewarn "Run this command:"
-                       ewarn "\trc-update add kmod-static-nodes sysinit"
-               fi
-       fi
-}