mail-filter/opendkim: new revision to fix liblua detection.
authorMichael Orlitzky <mjo@gentoo.org>
Tue, 28 Jan 2020 19:28:59 +0000 (14:28 -0500)
committerMichael Orlitzky <mjo@gentoo.org>
Tue, 28 Jan 2020 19:47:56 +0000 (14:47 -0500)
The ./configure script for OpenDKIM is all kinds of crazy when it
comes to detecting liblua. First, the PKG_CHECK_MODULES call was
looking for the wrong module, and I had to add the correct name to the
list. But then, once pkg-config could find liblua, it was doing the
wrong thing -- none of the "I have Lua support" commands were being
executed. So in a way it was fortunate that the old PKG_CHECK_MODULES
was failing. In any case, I've patched configure.ac to fix everything,
and will be sending a PR upstream.

This new revision adds that patch.

Closes: https://bugs.gentoo.org/704556
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
mail-filter/opendkim/files/opendkim-2.10.3-lua-pkgconfig.patch [new file with mode: 0644]
mail-filter/opendkim/opendkim-2.10.3-r18.ebuild [new file with mode: 0644]

diff --git a/mail-filter/opendkim/files/opendkim-2.10.3-lua-pkgconfig.patch b/mail-filter/opendkim/files/opendkim-2.10.3-lua-pkgconfig.patch
new file mode 100644 (file)
index 0000000..ee8d576
--- /dev/null
@@ -0,0 +1,174 @@
+From 1f1c947a983c49677544ab08dea3ea04869a8caf Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Sun, 26 Jan 2020 22:29:16 -0500
+Subject: [PATCH 1/1] configure.ac: check for "lua" with pkg-config in addition
+ to "lua5.1".
+
+The upstream Lua pkg-config file is named lua.pc, so unless some
+distribution renames it, OpenDKIM should be looking for "lua"
+and not "lua5.1" in its PKG_CHECK_MODULES call. In any case, we
+should definitely be checking for "lua", so this commit appends it
+to the list of modules we look for. The "lua5.1" module was left
+alone, because I don't know enough of the history to be sure that
+removing it is the right thing to do.
+
+When the call to PKG_CHECK_MODULES fails, OpenDKIM falls back to
+a manual search that looks in /usr/lib, and this can detect 32-bit
+libraries on a 64-bit system. Therefore it is preferable that the
+PKG_CHECK_MODULES call succeed.
+
+In the process of adding this fallback, I realized that some
+additional actions need to be performed in the success branch of
+the existing (and new) PKG_CHECK_MODULES call. The following
+three lines were added,
+
+  AC_SEARCH_LIBS([dlopen], [dl])
+  AC_SUBST([LUA_MANNOTICE], "")
+  AC_DEFINE([USE_LUA], 1, [support for Lua scripting])
+
+to tell various parts of OpenDKIM that we do indeed have Lua support.
+Afterwards, it became clear that those three lines could be factored
+out of *every* lua check, so that has been done as well.
+
+Closes: https://github.com/trusteddomainproject/OpenDKIM/issues/62
+Gentoo-bug: https://bugs.gentoo.org/704556
+---
+ configure.ac | 45 +++++++++++++++++----------------------------
+ 1 file changed, 17 insertions(+), 28 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index a478bb83..1d0db41a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1495,12 +1495,20 @@ lua_found="no"
+ if test \(  x"$luapath" = x"auto" -o x"$luapath" = x"yes" \) -a x"$PKG_CONFIG" != x""
+ then
+-        PKG_CHECK_MODULES([LIBLUA], [lua5.1],
+-                        [
+-                              lua_found="yes"
+-                              LIBLUA_INCDIRS="$LIBLUA_CFLAGS"
+-                        ],
+-                        [AC_MSG_WARN([pkg-config for Lua not found, trying manual search...])])
++  PKG_CHECK_MODULES([LIBLUA], [lua5.1], [
++      LIBLUA_INCDIRS="$LIBLUA_CFLAGS"
++      lua_found="yes"
++    ],
++    [
++      AC_MSG_WARN([pkg-config for lua5.1 not found, trying lua...])
++      PKG_CHECK_MODULES([LIBLUA], [lua], [
++          LIBLUA_INCDIRS="$LIBLUA_CFLAGS"
++          lua_found="yes"
++        ],
++      [AC_MSG_WARN([pkg-config for lua not found, trying manual search...])]
++      )
++    ]
++  )
+ fi
+ if test \( x"$luapath" = x"yes" -o x"$luapath" = x"auto" \) -a x"$lua_found" = x"no"
+@@ -1515,10 +1523,6 @@ then
+                       LIBLUA_INCDIRS="-I$d/include/lua51"
+                       LIBLUA_LIBDIRS="-L$d/lib/lua51"
+                       LIBLUA_LIBS="-llua -lm"
+-                      AC_SEARCH_LIBS([dlopen], [dl])
+-                      AC_DEFINE([USE_LUA], 1,
+-                                [support for Lua scripting])
+-                      AC_SUBST([LUA_MANNOTICE], "")
+                       lua_found="yes"
+                       break
+               elif test -f $d/include/lua52/lua.h
+@@ -1527,10 +1531,6 @@ then
+                       LIBLUA_INCDIRS="-I$d/include/lua52"
+                       LIBLUA_LIBDIRS="-L$d/lib/lua52"
+                       LIBLUA_LIBS="-llua -lm"
+-                      AC_SEARCH_LIBS([dlopen], [dl])
+-                      AC_DEFINE([USE_LUA], 1,
+-                                [support for Lua scripting])
+-                      AC_SUBST([LUA_MANNOTICE], "")
+                       lua_found="yes"
+                       break
+               elif test -f $d/include/lua5.1/lua.h
+@@ -1539,10 +1539,6 @@ then
+                       LIBLUA_INCDIRS="-I$d/include/lua5.1"
+                       LIBLUA_LIBDIRS="-L$d/lib"
+                       LIBLUA_LIBS="-llua5.1 -lm"
+-                      AC_SEARCH_LIBS([dlopen], [dl])
+-                      AC_DEFINE([USE_LUA], 1,
+-                                [support for Lua scripting])
+-                      AC_SUBST([LUA_MANNOTICE], "")
+                       lua_found="yes"
+                       break
+               elif test -f $d/include/lua5.2/lua.h
+@@ -1551,10 +1547,6 @@ then
+                       LIBLUA_INCDIRS="-I$d/include/lua5.2"
+                       LIBLUA_LIBDIRS="-L$d/lib"
+                       LIBLUA_LIBS="-llua5.2 -lm"
+-                      AC_SEARCH_LIBS([dlopen], [dl])
+-                      AC_DEFINE([USE_LUA], 1,
+-                                [support for Lua scripting])
+-                      AC_SUBST([LUA_MANNOTICE], "")
+                       lua_found="yes"
+                       break
+               elif test -f $d/include/lua.h
+@@ -1563,7 +1555,6 @@ then
+                       LIBLUA_INCDIRS="-I$d/include"
+                       LIBLUA_LIBDIRS="-L$d/lib"
+                       LIBLUA_LIBS="-llua -lm"
+-                      AC_SEARCH_LIBS([dlopen], [dl])
+                       lua_found="yes"
+                       break
+               fi
+@@ -1588,7 +1579,6 @@ then
+               LIBLUA_INCDIRS="-I$luapath/include/lua51"
+               LIBLUA_LIBDIRS="-L$luapath/lib/lua51"
+               LIBLUA_LIBS="-llua -lm"
+-              AC_SEARCH_LIBS([dlopen], [dl])
+               lua_found="yes"
+       elif test -f $luapath/include/lua52/lua.h
+       then
+@@ -1596,7 +1586,6 @@ then
+               LIBLUA_INCDIRS="-I$luapath/include/lua52"
+               LIBLUA_LIBDIRS="-L$luapath/lib/lua52"
+               LIBLUA_LIBS="-llua -lm"
+-              AC_SEARCH_LIBS([dlopen], [dl])
+               lua_found="yes"
+       elif test -f $luapath/include/lua5.1/lua.h
+       then
+@@ -1604,7 +1593,6 @@ then
+               LIBLUA_INCDIRS="-I$luapath/include/lua5.1"
+               LIBLUA_LIBDIRS="-L$luapath/lib"
+               LIBLUA_LIBS="-llua5.1 -lm"
+-              AC_SEARCH_LIBS([dlopen], [dl])
+               lua_found="yes"
+       elif test -f $luapath/include/lua5.2/lua.h
+       then
+@@ -1612,7 +1600,6 @@ then
+               LIBLUA_INCDIRS="-I$luapath/include/lua5.2"
+               LIBLUA_LIBDIRS="-L$luapath/lib"
+               LIBLUA_LIBS="-llua5.2 -lm"
+-              AC_SEARCH_LIBS([dlopen], [dl])
+               lua_found="yes"
+       elif test -f $luapath/include/lua.h
+       then
+@@ -1620,7 +1607,6 @@ then
+               LIBLUA_INCDIRS="-I$luapath/include"
+               LIBLUA_LIBDIRS="-L$luapath/lib"
+               LIBLUA_LIBS="-llua -lm"
+-              AC_SEARCH_LIBS([dlopen], [dl])
+               lua_found="yes"
+       else
+               AC_MSG_ERROR(not found at $luapath)
+@@ -1629,6 +1615,9 @@ fi
+ if test x"$lua_found" = x"yes"
+ then
++      AC_SUBST([LUA_MANNOTICE], "")
++      AC_DEFINE([USE_LUA], 1, [support for Lua scripting])
++      AC_SEARCH_LIBS([dlopen], [dl])
+       saved_CPPFLAGS="$CPPFLAGS"
+       CPPFLAGS="$outer_CPPFLAGS $LIBLUA_INCDIRS"
+       AC_MSG_CHECKING([Lua version])
+-- 
+2.24.1
+
diff --git a/mail-filter/opendkim/opendkim-2.10.3-r18.ebuild b/mail-filter/opendkim/opendkim-2.10.3-r18.ebuild
new file mode 100644 (file)
index 0000000..2600103
--- /dev/null
@@ -0,0 +1,228 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools db-use eutils systemd tmpfiles
+
+DESCRIPTION="A milter providing DKIM signing and verification"
+HOMEPAGE="http://opendkim.org/"
+SRC_URI="https://downloads.sourceforge.net/project/opendkim/${P}.tar.gz"
+
+# The GPL-2 is for the init script, bug 425960.
+LICENSE="BSD GPL-2 Sendmail-Open-Source"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="berkdb ldap libressl lmdb lua memcached opendbx poll sasl selinux +ssl static-libs stats querycache test unbound"
+
+BDEPEND="acct-user/opendkim
+       test? ( dev-lang/lua:* )"
+
+COMMON_DEPEND="|| ( mail-filter/libmilter mail-mta/sendmail )
+       dev-libs/libbsd
+       sys-apps/grep
+       ssl? (
+               !libressl? ( dev-libs/openssl:0= )
+               libressl? ( dev-libs/libressl:0= )
+       )
+       berkdb? ( >=sys-libs/db-3.2:* )
+       opendbx? ( >=dev-db/opendbx-1.4.0 )
+       lua? ( dev-lang/lua:* )
+       ldap? ( net-nds/openldap )
+       lmdb? ( dev-db/lmdb )
+       memcached? ( dev-libs/libmemcached )
+       sasl? ( dev-libs/cyrus-sasl )
+       unbound? ( >=net-dns/unbound-1.4.1:= net-dns/dnssec-root )
+       !unbound? ( net-libs/ldns )"
+
+DEPEND="${COMMON_DEPEND}"
+
+RDEPEND="${COMMON_DEPEND}
+       acct-user/opendkim
+       sys-process/psmisc
+       selinux? ( sec-policy/selinux-dkim )"
+
+REQUIRED_USE="sasl? ( ldap )
+       stats? ( opendbx )
+       querycache? ( berkdb )"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+       "${FILESDIR}/${P}-openrc.patch"
+       "${FILESDIR}/${P}-openssl-1.1.1.patch.r2"
+       "${FILESDIR}/${P}-lua-pkgconfig.patch"
+)
+
+src_prepare() {
+       default
+       sed -e 's:/var/db/dkim:/var/lib/opendkim:g' \
+               -i opendkim/opendkim.conf.sample opendkim/opendkim.conf.simple.in \
+               || die
+       sed -e 's:dist_doc_DATA:dist_html_DATA:' \
+               -i libopendkim/docs/Makefile.am \
+               || die
+       eautoreconf
+}
+
+src_configure() {
+       local myconf=()
+       if use berkdb ; then
+               myconf+=( --with-db-incdir=$(db_includedir) )
+       fi
+       if use unbound; then
+               myconf+=( --with-unbound )
+       else
+               myconf+=( --with-ldns )
+       fi
+       if use ldap; then
+               myconf+=( $(use_with sasl) )
+       fi
+
+       # We install the our configuration filed under e.g. /etc/opendkim,
+       # so the next line is necessary to point the daemon and all of its
+       # documentation to the right location by default.
+       myconf+=( --sysconfdir="${EPREFIX}/etc/${PN}" )
+
+       econf \
+               $(use_with berkdb db) \
+               $(use_with opendbx odbx) \
+               $(use_with lua) \
+               $(use_enable lua rbl) \
+               $(use_with ldap openldap) \
+               $(use_with lmdb) \
+               $(use_enable poll) \
+               $(use_enable querycache query_cache) \
+               $(use_enable static-libs static) \
+               $(use_enable stats) \
+               $(use_with memcached libmemcached) \
+               "${myconf[@]}" \
+               --enable-filter \
+               --enable-atps \
+               --enable-identity_header \
+               --enable-rate_limit \
+               --enable-resign \
+               --enable-replace_rules \
+               --enable-default_sender \
+               --enable-sender_macro \
+               --enable-vbr \
+               --disable-live-testing \
+               --with-test-socket="${T}/opendkim.sock"
+}
+
+src_compile() {
+       emake runstatedir=/run
+}
+
+src_install() {
+       default
+       find "${D}" -name '*.la' -type f -delete || die
+
+       dosbin stats/opendkim-reportstats
+
+       newinitd "${S}/contrib/OpenRC/opendkim.openrc" "${PN}"
+       systemd_newtmpfilesd "${S}/contrib/systemd/opendkim.tmpfiles" "${PN}.conf"
+       systemd_newunit "contrib/systemd/opendkim.service" "${PN}.service"
+
+       dodir /etc/opendkim
+       keepdir /var/lib/opendkim
+
+       # The OpenDKIM data (particularly, your keys) should be read-only to
+       # the UserID that the daemon runs as.
+       fowners root:opendkim /var/lib/opendkim
+       fperms 750 /var/lib/opendkim
+
+       # Tweak the "simple" example configuration a bit before installing
+       # it unconditionally.
+       local cf="${T}/opendkim.conf"
+       # Some MTAs are known to break DKIM signatures with "simple"
+       # canonicalization [1], so we choose the "relaxed" policy
+       # over OpenDKIM's current default settings.
+       # [1] https://wordtothewise.com/2016/12/dkim-canonicalization-or-why-microsoft-breaks-your-mail/
+       sed -E -e 's:^(Canonicalization)[[:space:]]+.*:\1\trelaxed/relaxed:' \
+               "${S}/opendkim/opendkim.conf.simple" >"${cf}" || die
+       cat >>"${cf}" <<EOT || die
+
+# The UMask is really only used for the PID file (root:root) and the
+# local UNIX socket, if you're using one. It should be 0117 for the
+# socket.
+UMask                  0117
+UserID                 opendkim
+
+# For use with unbound
+#TrustAnchorFile       /etc/dnssec/root-anchors.txt
+EOT
+       insinto /etc/opendkim
+       doins "${cf}"
+}
+
+pkg_postinst() {
+       tmpfiles_process "${PN}.conf"
+       if [[ -z ${REPLACING_VERSION} ]]; then
+               elog "If you want to sign your mail messages and need some help"
+               elog "please run:"
+               elog "  emerge --config ${CATEGORY}/${PN}"
+               elog "It will help you create your key and give you hints on how"
+               elog "to configure your DNS and MTA."
+
+               elog "If you are using a local (UNIX) socket, then you will"
+               elog "need to make sure that your MTA has read/write access"
+               elog "to the socket file. This is best accomplished by creating"
+               elog "a completely-new group with only your MTA user and the"
+               elog "\"opendkim\" user in it. Step-by-step instructions can be"
+               elog "found on our Wiki, at https://wiki.gentoo.org/wiki/OpenDKIM ."
+       else
+               ewarn "The user account for the OpenDKIM daemon has changed"
+               ewarn "from \"milter\" to \"opendkim\" to prevent unrelated services"
+               ewarn "from being able to read your private keys. You should"
+               ewarn "adjust your existing configuration to use the \"opendkim\""
+               ewarn "user and group, and change the permissions on"
+               ewarn "${ROOT}/var/lib/opendkim to root:opendkim with mode 0750."
+               ewarn "The owner and group of the files within that directory"
+               ewarn "will likely need to be adjusted as well."
+       fi
+}
+
+pkg_config() {
+       local selector keysize pubkey
+
+       read -p "Enter the selector name (default ${HOSTNAME}): " selector
+       [[ -n "${selector}" ]] || selector="${HOSTNAME}"
+       if [[ -z "${selector}" ]]; then
+               eerror "Oddly enough, you don't have a HOSTNAME."
+               return 1
+       fi
+       if [[ -f "${ROOT}/var/lib/opendkim/${selector}.private" ]]; then
+               ewarn "The private key for this selector already exists."
+       else
+               keysize=1024
+               # Generate the private and public keys. Note that opendkim-genkeys
+               # sets umask=077 on its own to keep these safe. However, we want
+               # them to be readable (only!) to the opendkim user, and we manage
+               # that by changing their groups and making everything group-readable.
+               opendkim-genkey -b ${keysize} -D "${ROOT}/var/lib/opendkim/" \
+                       -s "${selector}" -d '(your domain)' && \
+                       chgrp --no-dereference opendkim \
+                               "${ROOT}/var/lib/opendkim/${selector}".{private,txt} || \
+                               { eerror "Failed to create private and public keys."; return 1; }
+               chmod g+r "${ROOT}/var/lib/opendkim/${selector}".{private,txt}
+       fi
+
+       # opendkim selector configuration
+       echo
+       einfo "Make sure you have the following settings in your /etc/opendkim/opendkim.conf:"
+       einfo "  Keyfile /var/lib/opendkim/${selector}.private"
+       einfo "  Selector ${selector}"
+
+       # MTA configuration
+       echo
+       einfo "If you are using Postfix, add following lines to your main.cf:"
+       einfo "  smtpd_milters     = unix:/run/opendkim/opendkim.sock"
+       einfo "  non_smtpd_milters = unix:/run/opendkim/opendkim.sock"
+       einfo "  and read http://www.postfix.org/MILTER_README.html"
+
+       # DNS configuration
+       einfo "After you configured your MTA, publish your key by adding this TXT record to your domain:"
+       cat "${ROOT}/var/lib/opendkim/${selector}.txt"
+       einfo "t=y signifies you only test the DKIM on your domain. See following page for the complete list of tags:"
+       einfo "  http://www.dkim.org/specs/rfc4871-dkimbase.html#key-text"
+}