dev-python/oslo-serialization: 2.28.2 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 9 Apr 2019 04:59:32 +0000 (23:59 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 9 Apr 2019 07:04:55 +0000 (02:04 -0500)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/oslo-serialization/Manifest
dev-python/oslo-serialization/oslo-serialization-2.28.2.ebuild [new file with mode: 0644]

index f40005cea3fb6c765e87f297f6bd4f5f1aa969fc..e52bd8fc22760979360484a6fb8a45e78040a801 100644 (file)
@@ -1 +1,2 @@
 DIST oslo-serialization-2.24.0.tar.gz 28948 BLAKE2B 8e57d14b21deefd8058f4dd677493072b0bfdc08bfb18faae2f6a09c4ab4e29ce544e479427a6c6557e0ca78fd7b525aa6a8ab3443a01c3d856ee3556f5f3f5e SHA512 8c2103409d9ec2ebfd45eefb56ed42b1ca52c0f8eaf5deff1020a67f813c8524d1bffd81d97a1ad28c80b4a5afeaebca829c4580e635f514900fd0835782990c
+DIST oslo-serialization-2.28.2.tar.gz 30807 BLAKE2B ff0ee4d4215943d0fa419d0d0989c093812d354da6727f5e87a27ff0562baf5e3a22c781c686ce5156fcff065e03c7481bcf3e16041a2296366a1f297060eff5 SHA512 78305f20392348b73eca244464cd4167177cd82ea74597641ee9de60b51182e5e3d75e5d748fe2c39ddb322a08f2ee5044c846bc969022b738a0b89874451337
diff --git a/dev-python/oslo-serialization/oslo-serialization-2.28.2.ebuild b/dev-python/oslo-serialization/oslo-serialization-2.28.2.ebuild
new file mode 100644 (file)
index 0000000..3243829
--- /dev/null
@@ -0,0 +1,78 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Oslo Serialization library"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+       !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       ${CDEPEND}
+       test? (
+               virtual/python-ipaddress[${PYTHON_USEDEP}]
+               >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+               >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
+               >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
+               >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+               >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+               >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
+       )
+       doc? (
+               >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+               >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
+               >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+               >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
+       )
+"
+RDEPEND="
+       ${CDEPEND}
+       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+       >=dev-python/msgpack-0.5.2[${PYTHON_USEDEP}]
+       >=dev-python/oslo-utils-3.20.0[${PYTHON_USEDEP}]
+       >=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+       # allow useage of renamed msgpack
+       sed -i '/^msgpack/d' requirements.txt || die
+       use doc && esetup.py build_sphinx
+       distutils-r1_python_prepare_all
+}
+
+# Note: Tests fail due to requiring installation.
+#
+# Installation appears to fail due ot the use of namespace packages but root
+# cause was never truly established.
+RESTRICT="test"
+
+python_test() {
+       distutils_install_for_testing
+
+       PYTHONPATH="${TEST_DIR}/lib:${PYTHONPATH}"
+
+       rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPTYHON}"
+
+       testr init || die "testr init failed under ${EPYTHON}"
+       testr run || die "testr run failed under ${EPYTHON}"
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( doc/build/html/. )
+
+       distutils-r1_python_install_all
+}