net-mail/altermime: bump EAPI and stuff
authorAaron Bauman <bman@gentoo.org>
Sun, 10 Nov 2019 02:07:45 +0000 (21:07 -0500)
committerAaron Bauman <bman@gentoo.org>
Sun, 10 Nov 2019 02:07:45 +0000 (21:07 -0500)
Signed-off-by: Aaron Bauman <bman@gentoo.org>
net-mail/altermime/altermime-0.3.11.ebuild
net-mail/altermime/files/altermime-0.3.10-MIME_headers-overflow.patch
net-mail/altermime/files/altermime-0.3.11-respect-flags.patch

index 9d8ff8c549aefee2ae4317dda9e5a0bd9a612159..1e09d54ec526d087e77960c5cb4f9180cb9df1fc 100644 (file)
@@ -1,22 +1,24 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
-inherit eutils toolchain-funcs
+EAPI=7
+
+inherit toolchain-funcs
 
 DESCRIPTION=" alterMIME is a small program which is used to alter your mime-encoded mailpacks"
-SRC_URI="http://www.pldaniels.com/altermime/${P}.tar.gz"
-HOMEPAGE="http://pldaniels.com/altermime/"
+HOMEPAGE="https://pldaniels.com/altermime/"
+SRC_URI="https://www.pldaniels.com/altermime/${P}.tar.gz"
+
+KEYWORDS="amd64 ppc x86"
 
 LICENSE="Sendmail"
 SLOT="0"
-KEYWORDS="amd64 ppc x86"
 IUSE=""
 
-src_prepare() {
-       epatch "${FILESDIR}"/${PN}-0.3.10-MIME_headers-overflow.patch \
-               "${FILESDIR}"/${P}-respect-flags.patch
-}
+PATCHES=(
+       "${FILESDIR}"/${PN}-0.3.10-MIME_headers-overflow.patch
+       "${FILESDIR}"/${P}-respect-flags.patch
+)
 
 src_compile() {
        emake CC="$(tc-getCC)"
index bca39afba7f20c300e9f3084bb226a4ac3e28cd6..8d169e4bcf714cd4a79fa010da27b6d326c87c3c 100644 (file)
@@ -1,7 +1,7 @@
 http://bugs.gentoo.org/320785
 
---- MIME_headers.c
-+++ MIME_headers.c
+--- a/MIME_headers.c
++++ b/MIME_headers.c
 @@ -2243,7 +2243,7 @@
                {
                        if (MIMEH_DNORMAL) LOGGER_log("%s:%d:MIME_parse_contentlocation:DEBUG: filename = %s\n", FL, p);
index 9f114ca17491ccd471595d9048fd3d606891a571..f870414a2f6dd9d2e17f63c868005ac7d5050ef5 100644 (file)
@@ -1,5 +1,5 @@
---- altermime-0.3.11.orig/Makefile
-+++ altermime-0.3.11/Makefile
+--- a/Makefile
++++ b/Makefile
 @@ -9,7 +9,7 @@
  #                                                             opposite of a disclaimer.
  ALTERMIME_OPTIONS=-DALTERMIME_PRETEXT