dev-ruby/facter: fixing bad sed (by adding another sed) bug 560758
authorMatthew Thode <prometheanfire@gentoo.org>
Wed, 23 Sep 2015 02:41:24 +0000 (21:41 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Wed, 23 Sep 2015 02:41:50 +0000 (21:41 -0500)
Package-Manager: portage-2.2.20.1

dev-ruby/facter/facter-3.1.0.ebuild

index d27a6ebb594852d48c1974a3f7a3c6accc3b240a..31604763e41d602ca8facc9b3fd061eebdff3cee 100644 (file)
@@ -32,6 +32,7 @@ DEPEND+=" test? ( ${CDEPEND} )"
 src_prepare() {
        sed -i 's/\-Werror\ //g' "vendor/leatherman/cmake/cflags.cmake" || die
        # Remove the code that installs facter.rb to the wrong directory.
+       sed -i 's/if(RUBY_VENDORDIR)/if(False)/g' lib/CMakeLists.txt || die
        sed -i '/RUBY_VENDORDIR/d' lib/CMakeLists.txt || die
        # make it support multilib
        sed -i 's/\ lib)/\ lib${LIB_SUFFIX})/g' lib/CMakeLists.txt || die