gui-libs/wlroots: tweak for gcc-10. bug #707496
authorSergei Trofimovich <slyfox@gentoo.org>
Fri, 17 Apr 2020 17:23:18 +0000 (18:23 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Fri, 17 Apr 2020 17:23:31 +0000 (18:23 +0100)
Pull upstream f2943bdf61afe "Declare wlr_seat globals as extern".

Reported-by: Toralf Förster
Closes: https://bugs.gentoo.org/707496
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
gui-libs/wlroots/files/wlroots-0.10.0-gcc-10.patch [new file with mode: 0644]
gui-libs/wlroots/wlroots-0.10.0.ebuild

diff --git a/gui-libs/wlroots/files/wlroots-0.10.0-gcc-10.patch b/gui-libs/wlroots/files/wlroots-0.10.0-gcc-10.patch
new file mode 100644 (file)
index 0000000..44e1cb7
--- /dev/null
@@ -0,0 +1,26 @@
+https://bugs.gentoo.org/707496
+
+From f2943bdf61afe0a3ad2227d72fcbcac8b3088b1a Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Jan=20Stan=C4=9Bk?= <jstanek@redhat.com>
+Date: Tue, 28 Jan 2020 15:27:24 +0100
+Subject: [PATCH] Declare wlr_seat globals as extern
+
+---
+ include/types/wlr_seat.h | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+--- a/include/types/wlr_seat.h
++++ b/include/types/wlr_seat.h
+@@ -4,9 +4,9 @@
+ #include <wayland-server-core.h>
+ #include <wlr/types/wlr_seat.h>
+-const struct wlr_pointer_grab_interface default_pointer_grab_impl;
+-const struct wlr_keyboard_grab_interface default_keyboard_grab_impl;
+-const struct wlr_touch_grab_interface default_touch_grab_impl;
++extern const struct wlr_pointer_grab_interface default_pointer_grab_impl;
++extern const struct wlr_keyboard_grab_interface default_keyboard_grab_impl;
++extern const struct wlr_touch_grab_interface default_touch_grab_impl;
+ void seat_client_create_pointer(struct wlr_seat_client *seat_client,
+       uint32_t version, uint32_t id);
index f408a513a4de3fa5ef0c5108509709e7e40f8969..f1735761b73984d90cf35267592875f238cfc23b 100644 (file)
@@ -47,6 +47,8 @@ BDEPEND="
        virtual/pkgconfig
 "
 
+PATCHES=("${FILESDIR}"/${P}-gcc-10.patch)
+
 src_configure() {
        # xcb-util-errors is not on Gentoo Repository (and upstream seems inactive?)
        local emesonargs=(