dev-python/boto3: add live ebuild logic
authorAndrey Utkin <andrey_utkin@gentoo.org>
Mon, 25 Dec 2017 23:51:46 +0000 (23:51 +0000)
committerAndrey Utkin <andrey_utkin@gentoo.org>
Tue, 26 Dec 2017 02:04:49 +0000 (02:04 +0000)
Preparing to add 9999 boto3 ebuild due to high release frequency of
botocore and boto3.

Removed upper limit of botocore version requirement to allow -9999.

Package-Manager: Portage-2.3.17, Repoman-2.3.6

dev-python/boto3/boto3-1.5.6.ebuild

index e5e0c5c1a6565f94af1b71c26e675aa92b5f7cef..837af95fa1ea3413ee77510bd13db83a7bdf27a0 100644 (file)
@@ -8,16 +8,20 @@ inherit distutils-r1 vcs-snapshot
 
 DESCRIPTION="The AWS SDK for Python"
 HOMEPAGE="https://github.com/boto/boto3"
-SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
 LICENSE="Apache-2.0"
 SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
 IUSE="doc test"
 
+if [[ "${PV}" == "9999" ]]; then
+       EGIT_REPO_URI="https://github.com/boto/boto3"
+       inherit git-r3
+else
+       SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
 RDEPEND="
        >=dev-python/botocore-1.8.20[${PYTHON_USEDEP}]
-       <dev-python/botocore-1.9.0[${PYTHON_USEDEP}]
        >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
        <dev-python/jmespath-1.0.0[${PYTHON_USEDEP}]
        >=dev-python/s3transfer-0.1.10[${PYTHON_USEDEP}]