net-im/skypeforlinux: Version bump to 1.14.0.5
authorRaymond Jennings <shentino@gmail.com>
Sat, 17 Dec 2016 23:46:23 +0000 (18:46 -0500)
committerGöktürk Yüksek <gokturk@gentoo.org>
Sun, 18 Dec 2016 01:53:04 +0000 (20:53 -0500)
Gentoo-bug: 602928

Package-Manager: portage-2.3.0

net-im/skypeforlinux/Manifest
net-im/skypeforlinux/skypeforlinux-1.14.0.5.ebuild [new file with mode: 0644]

index abfaf9d33a7294f615f5186963ab19a43026b85a..236685ba1fdbbd5d220d1197daf30a159d08d5c3 100644 (file)
@@ -1 +1,2 @@
 DIST skypeforlinux_1.13.0.3-1.x86_64.rpm 63441090 SHA256 33f5bebdfc3d14dacbd14e10bbb6d7c95cb781112a4163dc0c43e38781e94886 SHA512 18d3cc9a18860c58b146b84e9409589b5d3bae9a35e1f06db088660869e71d5d35ca04a668ac103126cfc71c57021c419ef1ec8a958fb461dbdc891c6850ff20 WHIRLPOOL 6729406237f3599a109c3b36963def40c6f003a07a57b544416d57b1f0bcc0ac7c33e0970ce95cf41fd19168c1c6c2e3dc4a33d4acda72874ae4116d0642e04b
+DIST skypeforlinux_1.14.0.5-1.x86_64.rpm 63562538 SHA256 21c880ce78742994b69a1ce362ea1a000353196d44ea02cbbdbc23a180e8e5b3 SHA512 389d77b323a0876b7846b2a74ee01727e605a8389ef4a93072b2f07c18cea4103a91edb0c070d6cbac581e8a592e697442359b0c35e75f0fe4f7d7d571a5f54f WHIRLPOOL de5f1f9e193ff8abb5a6c4e5f6e4ffa0c7e8c7affacb36d04abb78089b1a4795c92cf5040ffa50c3cfa708fb2427bc981b10a8159443165fe1ba139db4d12349
diff --git a/net-im/skypeforlinux/skypeforlinux-1.14.0.5.ebuild b/net-im/skypeforlinux/skypeforlinux-1.14.0.5.ebuild
new file mode 100644 (file)
index 0000000..28b5b84
--- /dev/null
@@ -0,0 +1,112 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils rpm
+
+DESCRIPTION="P2P Internet Telephony (VoiceIP) client"
+HOMEPAGE="https://www.skype.com/"
+SRC_URI="https://repo.skype.com/rpm/stable/${PN}_${PV}-1.x86_64.rpm"
+
+LICENSE="Skype-TOS no-source-code"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="pax_kernel"
+
+S="${WORKDIR}"
+QA_PREBUILT=opt/skypeforlinux/skypeforlinux
+RESTRICT="mirror bindist strip" #299368
+
+RDEPEND="dev-libs/atk
+       dev-libs/expat
+       dev-libs/glib:2
+       dev-libs/nspr
+       dev-libs/nss
+       gnome-base/gconf:2
+       gnome-base/libgnome-keyring
+       media-libs/alsa-lib
+       media-libs/fontconfig:1.0
+       media-libs/freetype:2
+       net-print/cups
+       sys-apps/dbus
+       sys-devel/gcc[cxx]
+       sys-libs/glibc
+       virtual/ttf-fonts
+       x11-libs/cairo
+       x11-libs/gdk-pixbuf:2
+       x11-libs/gtk+:2
+       x11-libs/libX11
+       x11-libs/libXScrnSaver
+       x11-libs/libXcomposite
+       x11-libs/libXcursor
+       x11-libs/libXdamage
+       x11-libs/libXext
+       x11-libs/libXfixes
+       x11-libs/libXi
+       x11-libs/libXrandr
+       x11-libs/libXrender
+       x11-libs/libXtst
+       x11-libs/pango"
+
+src_unpack() {
+       rpm_src_unpack ${A}
+}
+
+src_prepare() {
+       default
+       sed -e "s!^SKYPE_PATH=.*!SKYPE_PATH=${EPREFIX}/opt/skypeforlinux/skypeforlinux!" \
+               -i usr/bin/skypeforlinux || die
+       sed -e "s!^Exec=.*!Exec=${EPREFIX}/opt/bin/skypeforlinux!" \
+               -e "s!^Categories=.*!Categories=Network;InstantMessaging;Telephony;!" \
+               -i usr/share/applications/skypeforlinux.desktop || die
+}
+
+src_install() {
+       insinto /opt/skypeforlinux/locales
+       doins usr/share/skypeforlinux/locales/*.pak
+
+       insinto /opt/skypeforlinux/resources/app.asar.unpacked/node_modules/keytar/build/Release
+       doins usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/keytar/build/Release/keytar.node
+
+       insinto /opt/skypeforlinux/resources
+       doins usr/share/skypeforlinux/resources/*.asar
+
+       insinto /opt/skypeforlinux
+       doins usr/share/skypeforlinux/*.pak
+       doins usr/share/skypeforlinux/*.bin
+       doins usr/share/skypeforlinux/*.dat
+       doins usr/share/skypeforlinux/version
+       exeinto /opt/skypeforlinux
+       doexe usr/share/skypeforlinux/*.so
+       doexe usr/share/skypeforlinux/skypeforlinux
+
+       into /opt
+       dobin usr/bin/skypeforlinux
+
+       dodoc -r usr/share/doc/skypeforlinux/.
+
+       doicon usr/share/pixmaps/skypeforlinux.png
+
+       local res
+       for res in 16 32 256 512; do
+               newicon -s ${res} usr/share/icons/hicolor/${res}x${res}/apps/skypeforlinux.png skypeforlinux.png
+       done
+
+       domenu usr/share/applications/skypeforlinux.desktop
+
+       if use pax_kernel; then
+               paxctl -Cm "${ED%/}"/opt/skypeforlinux/skypeforlinux || die
+               eqawarn "You have set USE=pax_kernel meaning that you intend to run"
+               eqawarn "${PN} under a PaX enabled kernel. To do so, we must modify"
+               eqawarn "the ${PN} binary itself and this *may* lead to breakage! If"
+               eqawarn "you suspect that ${PN} is being broken by this modification,"
+               eqawarn "please open a bug."
+       fi
+}
+
+pkg_postinst() {
+       einfo "See https://support.skype.com/en/faq/FA34656"
+       einfo "for more information about Skype for Linux Alpha."
+}