media-fonts/monoid: new ebuild
authorGuilherme Amadio <amadio@gentoo.org>
Mon, 10 Aug 2015 12:38:01 +0000 (14:38 +0200)
committerGuilherme Amadio <amadio@gentoo.org>
Mon, 10 Aug 2015 12:38:01 +0000 (14:38 +0200)
Thanks for José Romildo Malaquias <jrmalaq@gmail.com> for filing bug
556108 and for providing first ebuild.

Package-Manager: portage-2.2.18

media-fonts/monoid/Manifest [new file with mode: 0644]
media-fonts/monoid/metadata.xml [new file with mode: 0644]
media-fonts/monoid/monoid-0.60.ebuild [new file with mode: 0644]

diff --git a/media-fonts/monoid/Manifest b/media-fonts/monoid/Manifest
new file mode 100644 (file)
index 0000000..5697e4d
--- /dev/null
@@ -0,0 +1 @@
+DIST monoid-0.60.tar.gz 6294560 SHA256 4ace1b1655b369cffdb43264bc61f35f0c20586dffb112ce9c7a16ad2600fc0d SHA512 07159e938c26aafb15b6c9cceefcd10833d30a3c186f73b5185c1c912304de35ef575476770f33f20d4f5985cec14029962fd29a8fd1708a16c489dcedc9a3fb WHIRLPOOL bb423bfe6cbc80fe82e1c2057a2f7405305a18996bf04675bce76a1f1d89daf392b3824829d0996ecb6605e83baa60536e0f266a2097f80c6aace9b565e91ae7
diff --git a/media-fonts/monoid/metadata.xml b/media-fonts/monoid/metadata.xml
new file mode 100644 (file)
index 0000000..696065e
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>fonts</herd>
+</pkgmetadata>
diff --git a/media-fonts/monoid/monoid-0.60.ebuild b/media-fonts/monoid/monoid-0.60.ebuild
new file mode 100644 (file)
index 0000000..659aab6
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+inherit font multiprocessing
+
+DESCRIPTION="Open source coding font"
+HOMEPAGE="http://larsenwork.com/monoid https://github.com/larsenwork/monoid"
+SRC_URI="https://github.com/larsenwork/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="binchecks strip"
+
+DEPEND="media-gfx/fontforge[python]"
+RDEPEND=""
+
+FONT_SUFFIX="ttf"
+FONT_S="${S}/_release"
+DOCS="Readme.md"
+
+src_compile() {
+       local NJOBS=$(makeopts_jobs)
+       for x in Source/*.sfdir; do
+               Scripts/build.py ${NJOBS} ${NJOBS} $x
+       done
+}