dev-python/cheroot-8.3.0: Version bump
authorPatrick McLean <patrick.mclean@sony.com>
Thu, 26 Mar 2020 23:28:41 +0000 (16:28 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Thu, 26 Mar 2020 23:28:41 +0000 (16:28 -0700)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.96, Repoman-2.3.21
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/cheroot/Manifest
dev-python/cheroot/cheroot-8.3.0.ebuild [new file with mode: 0644]

index e3db8babde14ca4348e7909fecf9ccb45d2cb29c..08a0ae288ad03617b84f04c7ca9d43aa5967f8c8 100644 (file)
@@ -1 +1,2 @@
 DIST cheroot-8.2.1.tar.gz 89470 BLAKE2B 57515ecf6e047ea67599631a98c15307ea5f9929b398a8143bc157bfe71129b11a1f4bc841f586f98167ac4c6c9680d476bd167323e5828163b4bff9bf24c360 SHA512 3f6b55c6b2403569eedb1fe7b473d3a65ad5d06cb99a38370316db38b6138b1a6921c6b7d8ba64424c5b8c20c9c58ada33da7cb8ebb6f313610f63c1f364f862
+DIST cheroot-8.3.0.tar.gz 100557 BLAKE2B f5f2fd8a11a1a8660fc37030d501e93787be46dbb79cae89cb4f6915cbf3975453c0ced6ec3bc0ebfc7dc77d555f7d86ed01bd751df6b0227cac3b1b11a82ab5 SHA512 29ff39f043b1a08b9ef653a41761ac4b97de4141cf15c5394f95736d28f7fad4c501d666fe7ff61f40c55b087d022784c7fe09c995c901040b7f2a8ed16b7d14
diff --git a/dev-python/cheroot/cheroot-8.3.0.ebuild b/dev-python/cheroot/cheroot-8.3.0.ebuild
new file mode 100644 (file)
index 0000000..1c643f9
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Cheroot is the high-performance, pure-Python HTTP server used by CherryPy."
+HOMEPAGE="https://cherrypy.org/ https://pypi.org/project/Cheroot/ https://github.com/cherrypy/cheroot"
+SRC_URI="mirror://pypi/C/${PN/c/C}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+# Unit tests are temporarily disabled for this version, see below for
+# what needs to be done.
+#IUSE="test"
+RESTRICT="test"
+
+RDEPEND="
+       >=dev-python/six-1.11.0[${PYTHON_USEDEP}]
+       >=dev-python/more-itertools-2.6[${PYTHON_USEDEP}]
+       dev-python/jaraco-functools[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+       test? (
+               >=dev-python/pytest-mock-1.11.0[${PYTHON_USEDEP}]
+               >=dev-python/pytest-xdist-1.2.28[${PYTHON_USEDEP}]
+               dev-python/pyopenssl[${PYTHON_USEDEP}]
+       )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+       distutils-r1_python_prepare_all
+
+       sed -e "s/use_scm_version=True/version='${PV}'/" -i setup.py || die
+       sed -e '/setuptools_scm/d' -i setup.cfg || die
+}