dev-python/pyquery: Drop optional dep to optfeature
authorJustin Lecher <jlec@gentoo.org>
Fri, 25 Sep 2015 10:06:47 +0000 (12:06 +0200)
committerJustin Lecher <jlec@gentoo.org>
Fri, 25 Sep 2015 10:07:00 +0000 (12:07 +0200)
Package-Manager: portage-2.2.21
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/pyquery/Manifest
dev-python/pyquery/metadata.xml
dev-python/pyquery/pyquery-1.2.4.ebuild [deleted file]
dev-python/pyquery/pyquery-1.2.8.ebuild
dev-python/pyquery/pyquery-1.2.9-r1.ebuild
dev-python/pyquery/pyquery-1.2.9.ebuild

index 739b3fdfae523e4a4ec6491331ad47509d3f5ecb..91ab6dcb27b5a8883c12aabbdda322ab9d407ec1 100644 (file)
@@ -1,3 +1,2 @@
-DIST pyquery-1.2.4.tar.gz 23999 SHA256 1c39f786c42430279eadf787f1ef06873f15c9acba2698c23dfd925ac7b169d7 SHA512 77ec2efab157f693361e1dcbeabd7cac0709d3a8a25b6c47eb333be49c1485c7fa50b4fd9238bfff69657368130c2886cf6e0705415bdf1b48dc434365539c29 WHIRLPOOL 3fece4f710d69a0b57ab858f759196b269984a38af568003f7280215763c67b1e229feaf80f27b359a5da923248a11335026af4de85806ea6fc969c61c197685
 DIST pyquery-1.2.8.zip 42552 SHA256 59af39301bad397e085e5080987f94ef30672f1cf8e73d19d3307b3b63c3cb4b SHA512 9d344a5c4b0dd565e31c803ceecb217c71f9a70badbc65f9fcfb4a2cccb725a1bf938ed0b1697dcfdf0ec967321dccc1916a884ffdb0af9828a65005f63c47d7 WHIRLPOOL 5c98c3e7584d429a7c9bca564aac04e5dc6f579265aa9b8b768e167cdfcc57758b0d728b3102a56af75fa6ea838a6c1927e733a5171d3266574ba2b34ee85209
 DIST pyquery-1.2.9.zip 45289 SHA256 46c51eb878b787e814ee8f9737b0a62111034aeb4d1c06450ac5a8ea5a70e602 SHA512 f5152b471c896b39032add6a7f0e6ce63f426b4903bc7cf9eef12723c73453b40c310dd1497a7c4189fc6faaf804690fd91fb6d2f97fb6c4d6314682de4b8d05 WHIRLPOOL a57bb04402a3a8af98e7073d2b4e415a3e455bb67b4dc946831832f24339fe29fcd560123651abb3ae38c4ee9da3973638d27e064122702c0d1dd63d971fb67b
index 5609388fe1aabd1512cc48fd921cb369f6c332b5..a606518ddfc6fa7802bda3bbaeac5f44c03031af 100644 (file)
@@ -6,7 +6,4 @@
     <remote-id type="pypi">pyquery</remote-id>
     <remote-id type="github">gawel/pyquery</remote-id>
   </upstream>
-  <use>
-    <flag name="beautifulsoup3">Support BeautifulSoup 3</flag>
-  </use>
 </pkgmetadata>
diff --git a/dev-python/pyquery/pyquery-1.2.4.ebuild b/dev-python/pyquery/pyquery-1.2.4.ebuild
deleted file mode 100644 (file)
index 21a1e0d..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3} )
-
-inherit distutils-r1
-
-DESCRIPTION="A jQuery-like library for python"
-HOMEPAGE="https://pypi.python.org/pypi/pyquery"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~hppa ia64 ppc ~ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="beautifulsoup3 test"
-
-RDEPEND=">=dev-python/lxml-2.1[beautifulsoup3?,${PYTHON_USEDEP}]
-       dev-python/cssselect[${PYTHON_USEDEP}]
-       >=dev-python/webob-1.2_rc1[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-REQUIRED_USE="test? ( beautifulsoup3 )"
-
-DOCS=( CHANGES.rst README.rst )
-
-python_prepare_all() {
-       # Disable tests that access the net
-       for file in docs/{ajax.txt,manipulating.txt,scrap.txt,tips.txt}
-       do
-               mv ${file} ${file/.txt/}  || die
-       done
-       sed -e 's:>>> d = pq(url:>>> # d = pq(url:' -i README.rst || die
-       sed -e 's:class TestWebScrapping:class _TestWebScrapping:' -i ${PN}/test.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       nosetests || die "Tests fail with ${EPYTHON}"
-}
index fa371b17d203922e2c3e03e8da1da9c0c886f87c..4a02d400e46d7531b4a4e1651d18698c723cc26a 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -6,7 +6,7 @@ EAPI=5
 
 PYTHON_COMPAT=( python{2_7,3_3} )
 
-inherit distutils-r1
+inherit distutils-r1 eutils
 
 DESCRIPTION="A jQuery-like library for python"
 HOMEPAGE="https://github.com/gawel/pyquery"
@@ -15,9 +15,10 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="beautifulsoup3 test"
+IUSE="test"
 
-RDEPEND=">=dev-python/lxml-2.1[beautifulsoup3?,${PYTHON_USEDEP}]
+RDEPEND="
+       >=dev-python/lxml-2.1[${PYTHON_USEDEP}]
        dev-python/cssselect[${PYTHON_USEDEP}]
        >=dev-python/webob-1.2[${PYTHON_USEDEP}]
        dev-python/webtest[${PYTHON_USEDEP}]"
@@ -25,10 +26,10 @@ DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
        app-arch/unzip
        test? ( ${RDEPEND}
+               dev-python/beautifulsoup:python-2[$(python_gen_usedep 'python2*')]
+               dev-python/beautifulsoup:python-3[$(python_gen_usedep 'python3*')]
                dev-python/nose[${PYTHON_USEDEP}] )"
 
-REQUIRED_USE="test? ( beautifulsoup3 )"
-
 python_prepare_all() {
        # rm known failing tests and tests dependent on restkit
        # https://github.com/gawel/pyquery/pull/63/files
@@ -43,3 +44,7 @@ python_test() {
        # The suite, it appears, requires this hard setting of PYTHONPATH!
        PYTHONPATH=. nosetests || die "Tests fail with ${EPYTHON}"
 }
+
+pkg_postinst() {
+       optfeature "Support for BeautifulSoup3 as a parser backend" dev-python/beautifulsoup
+}
index 1344a4c73808fa248f1f5f5a9511e02ff14af0ee..580a69588fadeb68ae18488b728a5a0be847103c 100644 (file)
@@ -6,7 +6,7 @@ EAPI=5
 
 PYTHON_COMPAT=( python{2_7,3_3,3_4} )
 
-inherit distutils-r1
+inherit distutils-r1 eutils
 
 DESCRIPTION="A jQuery-like library for python"
 HOMEPAGE="https://github.com/gawel/pyquery"
@@ -15,23 +15,28 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
-IUSE="beautifulsoup3 test"
+IUSE="test"
 
-RDEPEND=">=dev-python/lxml-2.1[beautifulsoup3?,${PYTHON_USEDEP}]
+RDEPEND="
+       >=dev-python/lxml-2.1[${PYTHON_USEDEP}]
        >dev-python/cssselect-0.7.9[${PYTHON_USEDEP}]
        >=dev-python/webob-1.1.9[${PYTHON_USEDEP}]"
 DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
        app-arch/unzip
        test? ( ${RDEPEND}
+               dev-python/beautifulsoup:python-2[$(python_gen_usedep 'python2*')]
+               dev-python/beautifulsoup:python-3[$(python_gen_usedep 'python3*')]
                dev-python/requests[${PYTHON_USEDEP}]
                dev-python/nose[${PYTHON_USEDEP}]
                dev-python/webtest[${PYTHON_USEDEP}]
                $(python_gen_cond_dep 'dev-python/restkit[${PYTHON_USEDEP}]' 'python2_7') )"
 
-REQUIRED_USE="test? ( beautifulsoup3 )"
-
 python_test() {
        # The suite, it appears, requires this hard setting of PYTHONPATH!
        PYTHONPATH=. nosetests || die "Tests fail with ${EPYTHON}"
 }
+
+pkg_postinst() {
+       optfeature "Support for BeautifulSoup3 as a parser backend" dev-python/beautifulsoup
+}
index c556f77aa4a585aed4f27e2dd8e5ef0937a4cf7a..c738f3ac3d21b9e5fa023cf5f52320c3c03e366e 100644 (file)
@@ -6,7 +6,7 @@ EAPI=5
 
 PYTHON_COMPAT=( python{2_7,3_3,3_4} )
 
-inherit distutils-r1
+inherit distutils-r1 eutils
 
 DESCRIPTION="A jQuery-like library for python"
 HOMEPAGE="https://github.com/gawel/pyquery"
@@ -15,22 +15,27 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="alpha amd64 arm ~hppa ppc ppc64 sparc x86"
-IUSE="beautifulsoup3 test"
+IUSE="test"
 
-RDEPEND=">=dev-python/lxml-2.1[beautifulsoup3?,${PYTHON_USEDEP}]
+RDEPEND="
+       >=dev-python/lxml-2.1[${PYTHON_USEDEP}]
        >dev-python/cssselect-0.7.9[${PYTHON_USEDEP}]
        >=dev-python/webob-1.1.9[${PYTHON_USEDEP}]"
 DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
        app-arch/unzip
        test? ( ${RDEPEND}
+               dev-python/beautifulsoup:python-2[$(python_gen_usedep 'python2*')]
+               dev-python/beautifulsoup:python-3[$(python_gen_usedep 'python3*')]
                dev-python/requests[${PYTHON_USEDEP}]
                dev-python/nose[${PYTHON_USEDEP}]
                dev-python/webtest[${PYTHON_USEDEP}] )"
 
-REQUIRED_USE="test? ( beautifulsoup3 )"
-
 python_test() {
        # The suite, it appears, requires this hard setting of PYTHONPATH!
        PYTHONPATH=. nosetests || die "Tests fail with ${EPYTHON}"
 }
+
+pkg_postinst() {
+       optfeature "Support for BeautifulSoup3 as a parser backend" dev-python/beautifulsoup
+}