media-sound/setmixer: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Thu, 17 Oct 2019 22:37:44 +0000 (00:37 +0200)
committerDavid Seifert <soap@gentoo.org>
Thu, 17 Oct 2019 22:37:44 +0000 (00:37 +0200)
Bug: https://bugs.gentoo.org/697272
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: David Seifert <soap@gentoo.org>
media-sound/setmixer/setmixer-19941227_p1.ebuild

index 1ae45173a460226f12628d5a41513e49623ffb19..5a6817684f7a899e80d51499551003abcc8d7c3a 100644 (file)
@@ -1,40 +1,42 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
 
 MY_PV="27DEC94ds1"
 DEB_REV="1"
 
 DESCRIPTION="A commandline mixer"
-HOMEPAGE="http://packages.debian.org/unstable/sound/setmixer"
-SRC_URI="mirror://debian/pool/main/s/${PN}/${PN}_${MY_PV}.orig.tar.gz
+HOMEPAGE="https://packages.debian.org/unstable/sound/setmixer"
+SRC_URI="
+       mirror://debian/pool/main/s/${PN}/${PN}_${MY_PV}.orig.tar.gz
        mirror://debian/pool/main/s/${PN}/${PN}_${MY_PV}-${DEB_REV}.diff.gz"
 
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="amd64 ~ppc sparc x86"
-IUSE=""
 
-S=${WORKDIR}/${PN}-${MY_PV}.orig
+S="${WORKDIR}/${PN}-${MY_PV}.orig"
 
-src_unpack() {
-       unpack ${A}
-       epatch "${DISTDIR}"/${PN}_${MY_PV}-${DEB_REV}.diff.gz
-}
+PATCHES=( "${WORKDIR}"/${PN}_${MY_PV}-${DEB_REV}.diff )
 
 src_compile() {
-       emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" \
-               LDFLAGS="${LDFLAGS}" setmixer || die "emake failed."
+       emake \
+               CC="$(tc-getCC)" \
+               CFLAGS="${CFLAGS}" \
+               LDFLAGS="${LDFLAGS}" setmixer
 }
 
 src_install() {
        dobin setmixer
+
        dodoc README setmixer.lsm
        doman setmixer.1
+
        insinto /etc
        doins debian/setmixer.conf
+
        newinitd "${FILESDIR}"/setmixer.rc setmixer
 }