dev-perl/Try-Tiny: Bump to version 0.300.0
authorKent Fredric <kentnl@gentoo.org>
Wed, 14 Mar 2018 03:43:59 +0000 (16:43 +1300)
committerKent Fredric <kentnl@gentoo.org>
Wed, 14 Mar 2018 03:43:59 +0000 (16:43 +1300)
Upstream:
- 'finally' blocks are now run for all methods of leaving try block,
  including exit and goto
- Resolve pseudofork induced segfaults on windows by storing finalizers
  in a hash instead of an array
- Guard given/when tests against perl 5.27 release changes

Package-Manager: Portage-2.3.24, Repoman-2.3.6

dev-perl/Try-Tiny/Manifest
dev-perl/Try-Tiny/Try-Tiny-0.300.0.ebuild [new file with mode: 0644]

index 32b610b43c4ac2c0065f8a37d8c5ac369376a3d2..7add91f1d5362693a2e64fb096927378d2e07d05 100644 (file)
@@ -1,2 +1,3 @@
 DIST Try-Tiny-0.22.tar.gz 18311 BLAKE2B 0d7ed5fc560818b3bbb0aeb83279037e55a70333c35fac01aa42eadad52c26088a2efaecf9652f54f9232b7aab0a8b23bca195458c785827c507b409abf81d22 SHA512 4e39b4da16480bb2b93c05e8e016e9d1b5a68f29c527b19bbf9333442ca708e88dd2720a5812d141a152ae088ed1fcb1ce179018c2d0fe105545256396b2ccc4
 DIST Try-Tiny-0.24.tar.gz 30666 BLAKE2B aa9085787127f421b3fc5c8605c074d96033a3dd5e0afc3897c54b3654e08d1535c87af023261af52fdc55e9e61eac9e243d9f8975c646543619b213ba9a08b4 SHA512 403ce12b7cda7356b1a86d7661ed406ce4e526f416033fa5eb04b83bbeb7f198b4660342383232affe2ef9a8e0dbd237a6e6c0f290c277c8abc319c949d3c959
+DIST Try-Tiny-0.30.tar.gz 34395 BLAKE2B 5f128ec532e9091e0987bf8b0b540c38158b49d37af42f72366151f25da722e12b746626a242d8a8f7755d243ee5fe0232d1828d4f94ddac0c70ad9334b8a6d1 SHA512 f523736ab0504ca0f7150be312e62988c4b9473a9e8469b0746dc8364945e2922c64c92e95e6c2b5792c5d6399dabea3d00aa45c065155b95519d5658a07216c
diff --git a/dev-perl/Try-Tiny/Try-Tiny-0.300.0.ebuild b/dev-perl/Try-Tiny/Try-Tiny-0.300.0.ebuild
new file mode 100644 (file)
index 0000000..6e04d12
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.30
+inherit perl-module
+
+DESCRIPTION="Minimal try/catch with proper localization of \$@"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test minimal"
+
+RDEPEND="
+       !<=dev-perl/Try-Tiny-Except-0.10.0
+       !minimal? (
+               || ( >=virtual/perl-Scalar-List-Utils-1.400.0 dev-perl/Sub-Name )
+       )
+       virtual/perl-Carp
+       >=virtual/perl-Exporter-5.570.0
+"
+DEPEND="${RDEPEND}
+       virtual/perl-ExtUtils-MakeMaker
+       test? (
+               !minimal? (
+                       >=virtual/perl-CPAN-Meta-2.120.900
+                       >=dev-perl/Capture-Tiny-0.120.0
+               )
+               virtual/perl-File-Spec
+               virtual/perl-Test-Simple
+               virtual/perl-if
+       )
+"