dev-python/django-tagging: Bump to 0.5.0, py3.{7,8}
authorMichał Górny <mgorny@gentoo.org>
Tue, 21 Apr 2020 14:19:50 +0000 (16:19 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 21 Apr 2020 14:20:39 +0000 (16:20 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/django-tagging/Manifest
dev-python/django-tagging/django-tagging-0.5.0.ebuild [new file with mode: 0644]

index a4f90caa9318fd9de3e9dd6585865e7b26c4530f..c9727c73a35bcb3d85aa431e7e62a1aa796be0fc 100644 (file)
@@ -1 +1,2 @@
 DIST django-tagging-0.4.6.tar.gz 45228 BLAKE2B 77ed033ad61d227f8fea9e794b888da5d3a81474330d56bbbbcb1ce457ecac27d9615decadaece3c8b8fd2864c53342b795e8a76528c42609b928624609ccabe SHA512 75abf4b57df52393c8eb1ea265344c90c48b4225151076ce874b2e43657dd6cf4fffa1149acc2e118d58e3701d18103a362f658ce5114d7f207a33e7f4903b38
+DIST django-tagging-0.5.0.tar.gz 42827 BLAKE2B 0889af1ca2943c3bd8e4ffe3aecf8ceec85d2546daf9cccba06bbf9d34943ac7de41240ee79ab77797c6af490dc8dc2d3d9c7249b1c83d71488116e3fb78c0d3 SHA512 7a740c24cb9674f3e9c7f98aeb46f99537ba7afc79bbfd810004b921786e1246fe2ea1f219a2a6c414189497e7b9409bc4f7170714c6c03bb163ccede77c3266
diff --git a/dev-python/django-tagging/django-tagging-0.5.0.ebuild b/dev-python/django-tagging/django-tagging-0.5.0.ebuild
new file mode 100644 (file)
index 0000000..f20e767
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generic tagging application for Django"
+HOMEPAGE="https://pypi.org/project/django-tagging/
+       https://github.com/Fantomas42/django-tagging"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/django-1.0[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs
+
+python_test() {
+       local -x DJANGO_SETTINGS_MODULE=tagging.tests.settings
+       local -x PYTHONPATH=.
+       django-admin test -v 2 tagging || die "Tests failed with ${EPYTHON}"
+}