dev-python/pyserial: Use distutils_enable_sphinx
authorMichał Górny <mgorny@gentoo.org>
Fri, 22 Nov 2019 10:13:20 +0000 (11:13 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 25 Nov 2019 12:34:58 +0000 (13:34 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pyserial/pyserial-3.4.ebuild

index 2325d26c8f7cffe4ca4743ac79e177b2d6f9a5ce..64f8f963b2052f522da9dcfe4d6b1e5f763175b6 100644 (file)
@@ -13,28 +13,21 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 LICENSE="PSF-2"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="doc examples"
+IUSE="examples"
 
-DEPEND="
+BDEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx )
 "
 
-# Usual avoid d'loading un-needed objects.inv file
-PATCHES=( "${FILESDIR}"/mapping.patch )
-
 DOCS=( CHANGES.rst README.rst )
 
-python_compile_all() {
-       use doc && emake -C documentation html
-}
+distutils_enable_sphinx documentation --no-autodoc
 
 python_test() {
        "${EPYTHON}" test/run_all_tests.py loop:// -v || die "Testing failed with ${EPYTHON}"
 }
 
 python_install_all() {
-       use doc && local HTML_DOCS=( documentation/_build/html/. )
        distutils-r1_python_install_all
        if use examples; then
                dodoc -r examples