net-libs/libaccounts-glib: properly disable broken tests.
authorMichael Palimaka <kensington@gentoo.org>
Mon, 14 Sep 2015 15:06:14 +0000 (01:06 +1000)
committerMichael Palimaka <kensington@gentoo.org>
Mon, 14 Sep 2015 15:06:29 +0000 (01:06 +1000)
Gentoo-bug: 560456

Package-Manager: portage-2.2.20.1

net-libs/libaccounts-glib/libaccounts-glib-1.18.ebuild

index e50e0d431382f147e6a95b68cf4a55e7b8637a16..6f974fba62bbd52328aa27f1c95e8e3cac7dabe7 100644 (file)
@@ -4,6 +4,8 @@
 
 EAPI=5
 
+inherit autotools
+
 DESCRIPTION="Accounts SSO (Single Sign-On) management library for GLib applications"
 HOMEPAGE="https://01.org/gsso/"
 SRC_URI="http://dev.gentoo.org/~kensington/distfiles/${P}.tar.gz"
@@ -22,6 +24,11 @@ DEPEND="
 
 RDEPEND="$DEPEND"
 
+src_prepare() {
+       sed -i -e "/tests\/Makefile/d" configure.ac || die
+       eautoreconf
+}
+
 src_configure() {
        export HAVE_GCOV_FALSE='#'
        econf $(use_enable debug)