dev-python/yapf: Bump to version 0.28.0
authorFlorian Schmaus <flo@geekplace.eu>
Thu, 5 Sep 2019 19:23:23 +0000 (21:23 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Sun, 15 Sep 2019 16:48:42 +0000 (19:48 +0300)
Closes: https://bugs.gentoo.org/693580
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Florian Schmaus <flo@geekplace.eu>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-python/yapf/Manifest
dev-python/yapf/yapf-0.28.0.ebuild [new file with mode: 0644]

index b9394e3a98818bf330258af8c26ff85f5db976c5..220a9f394ccce0b13b116bb279b23f64ac8559dc 100644 (file)
@@ -1 +1,2 @@
 DIST yapf-0.24.0.tar.gz 145607 BLAKE2B 2f85130a28d7daea5f656bc3d46ef34291dfa3ac739170b8f7e120acbaa62c5f255c6c69d3b1775ceb13a63c09c239d207f227c41234bc676e131d0b4b958356 SHA512 daa61faaa2877af8bc8579b1f6a8e9cf177d1caf27e0430cc508b86b42d907186a0fe14913530368097b888f12c19fc601fbcc1c4e605341ca328e8bf40ea399
+DIST yapf-0.28.0.tar.gz 157976 BLAKE2B 11dbbecd4a9cd77e6ff3f1f279cc4302b13445e3f0522f64a7e6b71155703f4c074a5bbf08cedc903533aeaee7338c63a98fc04870b8470a30377686dc66d2b4 SHA512 be9ed5278d085797aba4a582a37295716c76fd10a4cea4bb5090794dd53eba6d1340d8ba7508e33a146f189a863578c95b0a651bbfd90b0390076028e03ad9bf
diff --git a/dev-python/yapf/yapf-0.28.0.ebuild b/dev-python/yapf/yapf-0.28.0.ebuild
new file mode 100644 (file)
index 0000000..b405b45
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 2018-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="A formatter for Python files"
+HOMEPAGE="https://github.com/google/yapf"
+SRC_URI="https://github.com/google/yapf/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_test() {
+       esetup.py test
+}