media-sound/flacon: update live ebuild
authorIlya Tumaykin <itumaykin@gmail.com>
Thu, 5 May 2016 01:12:27 +0000 (04:12 +0300)
committerIan Delaney <idella4@gentoo.org>
Tue, 10 May 2016 09:28:07 +0000 (17:28 +0800)
Bump EAPI to 6, update PLOCALES to make l10n happy.

Closes: https://github.com/gentoo/gentoo/pull/1440
Package-Manager: portage-2.2.28

Signed-off-by: Ian Delaney <idella4@gentoo.org>
media-sound/flacon/flacon-9999.ebuild

index c4026b58f2d9ad79157d86d5b5458c67dae10a04..2dcb6be032c99676c55da8dfbba4445f6e2b5308 100644 (file)
@@ -2,10 +2,10 @@
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
-EAPI=5
+EAPI=6
 
-# Ignore rudimentary et, uz@Latn, zh_TW translation(s)
-PLOCALES="cs_CZ cs de es_MX es fr gl hu it ja_JP lt nb pl_PL pl pt_BR pt_PT ro_RO ru sr tr uk zh_CN"
+# Ignore rudimentary et, uz@Latn, zh_TW translation(s).
+PLOCALES="cs cs_CZ de es es_MX fr gl hu it ja_JP lt nb pl pl_PL pt_BR pt_PT ro_RO ru sr tr uk zh_CN"
 
 inherit cmake-utils fdo-mime gnome2-utils l10n virtualx git-r3
 
@@ -57,7 +57,9 @@ DEPEND="${COMMON_DEPEND}
 REQUIRED_USE="^^ ( qt4 qt5 )"
 
 src_prepare() {
-       # Ignore rudimentary et, uz@Latn, zh_TW translation(s)
+       cmake-utils_src_prepare
+
+       # Ignore rudimentary et, uz@Latn, zh_TW translation(s).
        rm "translations/${PN}_uz@Latn.desktop" || die
        rm "translations/${PN}"_{et,zh_TW}.ts || die
 
@@ -67,8 +69,6 @@ src_prepare() {
 
        l10n_find_plocales_changes 'translations' "${PN}_" '.ts'
        l10n_for_each_disabled_locale_do remove_locale
-
-       cmake-utils_src_prepare
 }
 
 src_configure() {