dev-python/aws-sam-translator-1.22.0: bump, add py38
authorPatrick McLean <patrick.mclean@sony.com>
Wed, 29 Apr 2020 20:49:30 +0000 (13:49 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Wed, 29 Apr 2020 20:54:47 +0000 (13:54 -0700)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/aws-sam-translator/Manifest
dev-python/aws-sam-translator/aws-sam-translator-1.22.0.ebuild [new file with mode: 0644]

index eb46b6cecbd44b078648df508a76179cb00003e1..bdaa405d3933db5e1790080aa7f9b633420d1647 100644 (file)
@@ -1 +1,2 @@
 DIST aws-sam-translator-1.11.0.tar.gz 96492 BLAKE2B 4025492501d17699b64041a94704d0ec491ffb02a4b7e48c2647101be4d504b6a8c08a9a043c2d964a51d1ef7b40e4fd1d993f9d3b38b5b75460a7d0117b9f49 SHA512 e008248ef3401ffe58590c6d68667f67e5963e416656daea545c8d938ab8cb5d8b1c9c7f5aea2d53cedfd74b1fb8677e99a93a8a78235198b18c14df957d0c74
+DIST aws-sam-translator-1.22.0.tar.gz 5092855 BLAKE2B 596d4162938889fd7fc1dcddfa7317bc772b2a5629940a2a0ce1329c8e05c063872ce15dce95d99aadbb80409c015c00a5ce0e4f066de2609f21008e3c5c1faa SHA512 070a9d72683251d11c3f3d41d5ae5e51249f27bd8c7890fb77254b81e9e1267fd2324dac7a246b2b1067210da9beb78cb97dc0f4a31b29e3990a300a05bd4a4a
diff --git a/dev-python/aws-sam-translator/aws-sam-translator-1.22.0.ebuild b/dev-python/aws-sam-translator/aws-sam-translator-1.22.0.ebuild
new file mode 100644 (file)
index 0000000..cea1f43
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="A library that transform SAM templates into AWS CloudFormation templates"
+HOMEPAGE="https://github.com/awslabs/serverless-application-model https://pypi.org/project/aws-sam-translator/"
+SRC_URI="https://github.com/awslabs/serverless-application-model/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/serverless-application-model-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+       >=dev-python/boto3-1.5[${PYTHON_USEDEP}]
+       >=dev-python/jsonschema-2.6[${PYTHON_USEDEP}]
+       >=dev-python/six-1.11[${PYTHON_USEDEP}]
+"
+BDEPEND="
+       test? ( ${RDEPEND}
+               dev-python/mock[${PYTHON_USEDEP}]
+               dev-python/parameterized[${PYTHON_USEDEP}]
+       )
+"
+RESTRICT="!test? ( test )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+       # remove pytest-cov dependency
+       sed -r -e 's:--cov(-[[:graph:]]+|)[[:space:]]+[[:graph:]]+::g' \
+               -i pytest.ini || die
+
+       # don't install tests
+       sed -e 's:"tests",:"tests", "tests.*",:' -i setup.py || die
+
+       # deps are installed by ebuild, don't try to reinstall them via pip
+       truncate --size=0 requirements/*.txt || die
+
+       distutils-r1_python_prepare_all
+}