app-misc/fdupes: remove stdin as lvalue, bug #574610
authorAnthony G. Basile <blueness@gentoo.org>
Mon, 29 Feb 2016 07:53:08 +0000 (02:53 -0500)
committerAnthony G. Basile <blueness@gentoo.org>
Mon, 29 Feb 2016 07:53:33 +0000 (02:53 -0500)
Package-Manager: portage-2.2.26

app-misc/fdupes/fdupes-1.51.ebuild
app-misc/fdupes/files/fdupes-1.51-fix-stdin-lvalue.patch [new file with mode: 0644]

index 6bff666e0637811f8728b584f5e4c88c6f1118df..8037f87721df63753b028e475b447edeb959dcb9 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -26,7 +26,8 @@ src_prepare() {
        epatch \
                "${FILESDIR}"/${P}-makefile.patch \
                "${FILESDIR}"/${PN}-1.50_pre2-compare-file.patch \
-               "${FILESDIR}"/${PN}-1.50_pre2-typo.patch
+               "${FILESDIR}"/${PN}-1.50_pre2-typo.patch \
+               "${FILESDIR}"/${P}-fix-stdin-lvalue.patch
 
        append-lfs-flags
 }
diff --git a/app-misc/fdupes/files/fdupes-1.51-fix-stdin-lvalue.patch b/app-misc/fdupes/files/fdupes-1.51-fix-stdin-lvalue.patch
new file mode 100644 (file)
index 0000000..65c06e3
--- /dev/null
@@ -0,0 +1,20 @@
+This is a combination of upstream's fe2d8334 and 03abad.  See
+https://bugs.gentoo.org/show_bug.cgi?id=574610.
+
+diff -Naur fdupes-1.51.orig/fdupes.c fdupes-1.51/fdupes.c
+--- fdupes-1.51.orig/fdupes.c  2013-04-20 14:02:18.000000000 -0400
++++ fdupes-1.51/fdupes.c       2016-02-29 02:45:36.360804360 -0500
+@@ -1164,7 +1164,12 @@
+     }
+     else
+     {
+-      stdin = freopen("/dev/tty", "r", stdin);
++      if (freopen("/dev/tty", "r", stdin) == 0)
++      {
++        errormsg("could not open terminal for input\n");
++        exit(1);
++      }
++
+       deletefiles(files, 1, stdin);
+     }
+   }