ros-meta/robot_model: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Tue, 22 Sep 2015 18:56:44 +0000 (20:56 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 22 Sep 2015 18:57:06 +0000 (20:57 +0200)
Package-Manager: portage-2.2.21

ros-meta/robot_model/Manifest [new file with mode: 0644]
ros-meta/robot_model/metadata.xml [new file with mode: 0644]
ros-meta/robot_model/robot_model-1.11.8.ebuild [new file with mode: 0644]
ros-meta/robot_model/robot_model-9999.ebuild [new file with mode: 0644]

diff --git a/ros-meta/robot_model/Manifest b/ros-meta/robot_model/Manifest
new file mode 100644 (file)
index 0000000..89a3e8c
--- /dev/null
@@ -0,0 +1 @@
+DIST robot_model-1.11.8.tar.gz 364741 SHA256 781a0510136a820d217862f7491183b3deeadaf18aa0fabeb28d79e365510e12 SHA512 65471bb58c7383987f587a61f9e32fbd991c4eb26f1d5a819db8a5f456def7566ab9d16ab343a885fba73e0a017f5729815501356ef85b6aff0b4f0544a41212 WHIRLPOOL 95a9e654c1e7324593d2671a37b4c16aeee373450d5cb52508435b643c80c72c7263506914459c3c320af47355129dc0e906cdfb30d0e3bda1fd418e016e3a39
diff --git a/ros-meta/robot_model/metadata.xml b/ros-meta/robot_model/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/ros-meta/robot_model/robot_model-1.11.8.ebuild b/ros-meta/robot_model/robot_model-1.11.8.ebuild
new file mode 100644 (file)
index 0000000..66cc294
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/robot_model"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Packages for modeling various aspects of robot information"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/collada_parser
+       dev-ros/collada_urdf
+       dev-ros/joint_state_publisher
+       dev-ros/kdl_parser
+       dev-ros/urdf
+       dev-ros/urdf_parser_plugin
+"
+DEPEND="${RDEPEND}"
diff --git a/ros-meta/robot_model/robot_model-9999.ebuild b/ros-meta/robot_model/robot_model-9999.ebuild
new file mode 100644 (file)
index 0000000..66cc294
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/robot_model"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Packages for modeling various aspects of robot information"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/collada_parser
+       dev-ros/collada_urdf
+       dev-ros/joint_state_publisher
+       dev-ros/kdl_parser
+       dev-ros/urdf
+       dev-ros/urdf_parser_plugin
+"
+DEPEND="${RDEPEND}"