dev-python/psutil: Port to py39
authorMichał Górny <mgorny@gentoo.org>
Tue, 26 May 2020 09:59:02 +0000 (11:59 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 26 May 2020 10:35:43 +0000 (12:35 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/psutil/psutil-5.7.0.ebuild

index affbb558aa450d00592954858f94fbb65966da9a..2160825ab22885c56f90acdceefe401909a6602f 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
 
 inherit distutils-r1
 
@@ -17,7 +17,6 @@ IUSE="test"
 RESTRICT="!test? ( test )"
 
 DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
                $(python_gen_cond_dep '
                        dev-python/mock[${PYTHON_USEDEP}]