x11-plugins/purple-facebook: 0.9.6 version bump
authorTony Vroon <chainsaw@gentoo.org>
Mon, 21 Jan 2019 14:00:25 +0000 (14:00 +0000)
committerTony Vroon <chainsaw@gentoo.org>
Mon, 21 Jan 2019 14:00:25 +0000 (14:00 +0000)
As requested by Gabriel, this adds the recent 0.9.6 release.
This will address "Failed to read fixed header" as reported
by Kobboi.

Closes: https://bugs.gentoo.org/673586
Closes: https://bugs.gentoo.org/675392
Signed-Off-By: Tony Vroon <chainsaw@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

x11-plugins/purple-facebook/Manifest
x11-plugins/purple-facebook/purple-facebook-20190113.ebuild [new file with mode: 0644]

index 98fd0abb0dd84f0f1d6a631d2456df5a8e9d0658..908c8263b13ea1798daba1e64f1b8e71e4d5c7b4 100644 (file)
@@ -1,2 +1,3 @@
 DIST purple-facebook-20170608.tar.gz 459535 BLAKE2B 24dcb59496efde8f176c48872b30568ac50c09456056b564f692ad96ee0a76691f19c5282abc4af37fbea5cde7fa43f151cb80217e6dba694f10d0e2cd118eaa SHA512 50e8708afc059239347ccf1a5b92202469116848c63599cfc450d114f2b821a9c15ef340074e715ffebd46761b30f59ac8caf9bb2848af41c3ad0abc39fb39e2
 DIST purple-facebook-20170831.tar.gz 462381 BLAKE2B 06f2f53885b11842f76c6d04d5c85ba78461cbaef46962ff058432a491a3e0e47653c2d04b5b4f0cc77a21e0cea08d1b302fe0116341df70caa4416180965fba SHA512 0e90543b1b2ea24482b26b45ccd6b7d557f10cdcf1d5f535f8c47a0bc9721e5a1049d55705e2f360702d5ad52511f17cf1a7f353b69b62497890dd6b75f6cc83
+DIST purple-facebook-20190113.tar.gz 474005 BLAKE2B 5deb89724ed12280ae29274a03556cc0609f9bcae537786f702d59a35ee2c820bea44bad62a0f6393680da4ea86eb86a2aa8649ab5bdebc43ccc3d6325f8b9a3 SHA512 bf2284169f6765986279421ad9946610de6f58a79d0b70e7dbd43445f59dc518aabdb8a9b41c9f1c8441c12edce79ecfaf7e98bdc56abdc59bb2c46951ee50ce
diff --git a/x11-plugins/purple-facebook/purple-facebook-20190113.ebuild b/x11-plugins/purple-facebook/purple-facebook-20190113.ebuild
new file mode 100644 (file)
index 0000000..5954a74
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_PV="0.9.6"
+S="${WORKDIR}/${PN}-${MY_PV}"
+DESCRIPTION="Facebook protocol plugin for libpurple"
+HOMEPAGE="https://github.com/dequis/purple-facebook"
+SRC_URI="https://github.com/dequis/${PN}/releases/download/v${MY_PV}/${PN}-${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-libs/json-glib
+        net-im/pidgin"
+DEPEND="${RDEPEND}"
+DOCS=( AUTHORS ChangeLog NEWS README VERSION )
+
+src_prepare() {
+       default
+       eautoreconf
+}