media-libs/oyranos: Fix mesa build error, drop multilib remnant, use xdg
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 26 Dec 2019 23:42:26 +0000 (00:42 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 26 Dec 2019 23:51:01 +0000 (00:51 +0100)
Closes: https://bugs.gentoo.org/671996
Closes: https://bugs.gentoo.org/672004
Closes: https://bugs.gentoo.org/672006
Closes: https://bugs.gentoo.org/680324
Closes: https://bugs.gentoo.org/689686
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-libs/oyranos/files/oyranos-0.9.6-mesa-18.3.1.patch [new file with mode: 0644]
media-libs/oyranos/files/oyranos-0.9.6-underlinking.patch [new file with mode: 0644]
media-libs/oyranos/oyranos-0.9.6-r1.ebuild
media-libs/oyranos/oyranos-9999.ebuild

diff --git a/media-libs/oyranos/files/oyranos-0.9.6-mesa-18.3.1.patch b/media-libs/oyranos/files/oyranos-0.9.6-mesa-18.3.1.patch
new file mode 100644 (file)
index 0000000..83ed82a
--- /dev/null
@@ -0,0 +1,24 @@
+From ac7bdc35ea376f938ad223b0156a04a2af6d2eff Mon Sep 17 00:00:00 2001
+From: Kai-Uwe Behrmann <ku.b@gmx.de>
+Date: Fri, 28 Dec 2018 00:14:24 +0100
+Subject: [PATCH] * [exmpl]: update GLee.h to Mesa-18.3.1
+
+the include guards of system files changed
+---
+ src/examples/image_display/GLee.h | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/examples/image_display/GLee.h b/src/examples/image_display/GLee.h
+index 2edca003..01b19c68 100644
+--- a/src/examples/image_display/GLee.h
++++ b/src/examples/image_display/GLee.h
+@@ -61,7 +61,9 @@
+       #include <OpenGL/gl.h>
+ #else // GLX
+       #define __glext_h_  /* prevent glext.h from being included  */
++      #define __gl_glext_h_
+       #define __glxext_h_ /* prevent glxext.h from being included */
++      #define __glx_glxext_h_
+       #define GLX_GLXEXT_PROTOTYPES
+       #include <GL/gl.h>
+       #include <GL/glx.h>
diff --git a/media-libs/oyranos/files/oyranos-0.9.6-underlinking.patch b/media-libs/oyranos/files/oyranos-0.9.6-underlinking.patch
new file mode 100644 (file)
index 0000000..b25a36c
--- /dev/null
@@ -0,0 +1,16 @@
+Index: oyranos-0.9.6/src/modules/color/modules/CMakeLists.txt
+===================================================================
+--- oyranos-0.9.6.orig/src/modules/color/modules/CMakeLists.txt
++++ oyranos-0.9.6/src/modules/color/modules/CMakeLists.txt
+@@ -74,9 +74,9 @@ SET( OY_MODULE oydi )
+ SET( OY_MODULE_LIB ${PACKAGE_NAME}_${OY_MODULE}${OY_MODULE_NAME} )
+ ADD_LIBRARY( ${OY_MODULE_LIB}
+              SHARED ${PACKAGE_NAME}_cmm_${OY_MODULE}.c )
+-TARGET_LINK_LIBRARIES ( ${OY_MODULE_LIB} ${PROJECT_NAME} ${EXTRA_LIBS} ${XCM_LIBRARIES} ${XFIXES_LIBRARIES} )
++TARGET_LINK_LIBRARIES ( ${OY_MODULE_LIB} ${PROJECT_NAME} ${EXTRA_LIBS} ${XCM_LIBRARIES} ${XFIXES_LIBRARIES} ${X11_LIBRARIES} )
+ INSTALL (TARGETS ${OY_MODULE_LIB} DESTINATION ${CMAKE_INSTALL_LIBDIR}/${OY_CMMSUBPATH})
+-SET( OY_MODULE_LIBRARIES ${OY_MODULE_LIBRARIES} ${XCM_LIBRARIES} ${XFIXES_LIBRARIES} )
++SET( OY_MODULE_LIBRARIES ${OY_MODULE_LIBRARIES} ${XCM_LIBRARIES} ${XFIXES_LIBRARIES} ${X11_LIBRARIES} )
+ SET( OY_MODULE oyra )
+ SET( OY_MODULE_LIB ${PACKAGE_NAME}_${OY_MODULE}${OY_MODULE_NAME} )
index 05b026fa3e9de3bb960400e33ff7bebaa0dd93d0..4eee55d10f7d21e0602fdbc838b7723fecb2098d 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -12,7 +12,7 @@ else
        KEYWORDS="~amd64 ~x86"
 fi
 CMAKE_REMOVE_MODULES_LIST="${CMAKE_REMOVE_MODULES_LIST} FindXcm FindCUPS"
-inherit cmake-utils flag-o-matic
+inherit cmake-utils flag-o-matic xdg
 
 DESCRIPTION="Colour management system allowing to share settings across apps and services"
 HOMEPAGE="https://www.oyranos.org/"
@@ -69,7 +69,11 @@ DOCS=( {AUTHORS,ChangeLog,README}.md )
 
 RESTRICT="test"
 
-PATCHES=( "${WORKDIR}/patches" )
+PATCHES=(
+       "${WORKDIR}/patches"
+       "${FILESDIR}/${P}-mesa-18.3.1.patch" # bug 671996
+       "${FILESDIR}/${P}-underlinking.patch"
+)
 
 src_prepare() {
        # remove bundled libs
@@ -77,7 +81,7 @@ src_prepare() {
        cmake-utils_src_prepare
 }
 
-multilib_src_configure() {
+src_configure() {
        local mycmakeargs=(
                -DCMAKE_INSTALL_DOCDIR=share/doc/${PF}
                -DUSE_SYSTEM_ELEKTRA=ON
index a44af27aa9ea3566c7aa68b506fd3b3141bec707..9d14bb4f921a6c225ae9dcbe521a9e1b2cf6492b 100644 (file)
@@ -11,7 +11,7 @@ else
        KEYWORDS="~amd64 ~x86"
 fi
 CMAKE_REMOVE_MODULES_LIST="${CMAKE_REMOVE_MODULES_LIST} FindXcm FindCUPS"
-inherit cmake-utils flag-o-matic
+inherit cmake-utils flag-o-matic xdg
 
 DESCRIPTION="Colour management system allowing to share settings across apps and services"
 HOMEPAGE="https://www.oyranos.org/"
@@ -74,7 +74,7 @@ src_prepare() {
        cmake-utils_src_prepare
 }
 
-multilib_src_configure() {
+src_configure() {
        local mycmakeargs=(
                -DCMAKE_INSTALL_DOCDIR=share/doc/${PF}
                -DUSE_SYSTEM_ELEKTRA=ON