sys-fs/zfs-kmod: update live ebuild, it's OpenZFS now
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Tue, 14 Apr 2020 21:40:40 +0000 (14:40 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Tue, 14 Apr 2020 23:02:50 +0000 (16:02 -0700)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
sys-fs/zfs-kmod/zfs-kmod-9999.ebuild

index 87090d4d5e0fd90a3cff5c4744f231ad29eeac16..961b19b85da078df326c201e7b7510130c06c225 100644 (file)
@@ -6,16 +6,16 @@ EAPI=7
 inherit flag-o-matic linux-mod toolchain-funcs
 
 DESCRIPTION="Linux ZFS kernel module for sys-fs/zfs"
-HOMEPAGE="https://zfsonlinux.org/"
+HOMEPAGE="https://github.com/openzfs/zfs"
 
 if [[ ${PV} == "9999" ]]; then
        inherit autotools git-r3
-       EGIT_REPO_URI="https://github.com/zfsonlinux/zfs.git"
+       EGIT_REPO_URI="https://github.com/openzfs/zfs.git"
 else
-       SRC_URI="https://github.com/zfsonlinux/zfs/releases/download/zfs-${PV}/zfs-${PV}.tar.gz"
+       SRC_URI="https://github.com/openzfs/zfs/releases/download/zfs-${PV}/zfs-${PV}.tar.gz"
        KEYWORDS="~amd64 ~arm64 ~ppc64"
        S="${WORKDIR}/zfs-${PV}"
-       ZFS_KERNEL_COMPAT="5.4"
+       ZFS_KERNEL_COMPAT="5.6"
 fi
 
 LICENSE="CDDL debug? ( GPL-2+ )"
@@ -150,7 +150,7 @@ pkg_postinst() {
                ewarn "at least 256M and decreasing zfs_arc_max to some value less than that."
        fi
 
-       ewarn "This version of ZFSOnLinux includes support for new feature flags"
+       ewarn "This version of OpenZFS includes support for new feature flags"
        ewarn "that are incompatible with previous versions. GRUB2 support for"
        ewarn "/boot with the new feature flags is not yet available."
        ewarn "Do *NOT* upgrade root pools to use the new feature flags."