media-gfx/gimmage: Bump to EAPI=5
authorJustin Lecher <jlec@gentoo.org>
Fri, 18 Sep 2015 07:48:30 +0000 (09:48 +0200)
committerJustin Lecher <jlec@gentoo.org>
Fri, 18 Sep 2015 07:49:08 +0000 (09:49 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
media-gfx/gimmage/gimmage-0.2.3-r1.ebuild [new file with mode: 0644]

diff --git a/media-gfx/gimmage/gimmage-0.2.3-r1.ebuild b/media-gfx/gimmage/gimmage-0.2.3-r1.ebuild
new file mode 100644 (file)
index 0000000..7878b32
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="A slim GTK-based image browser"
+HOMEPAGE="https://sourceforge.net/projects/gimmage.berlios/"
+SRC_URI="mirror://sourceforge/project/${PN}.berlios/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+RDEPEND="
+       dev-cpp/cairomm
+       >=dev-cpp/gtkmm-2.6.2:2.4
+       net-misc/curl
+       sys-apps/file"
+DEPEND="${RDEPEND}
+       sys-devel/gettext
+       virtual/pkgconfig"
+
+src_prepare() {
+       epatch \
+               "${FILESDIR}"/${P}-gcc43.patch \
+               "${FILESDIR}"/${P}-as-needed.patch \
+               "${FILESDIR}"/${P}-desktop-entry.patch \
+               "${FILESDIR}"/${P}-gcc47.patch
+       eautoreconf
+}
+
+src_configure() {
+       local myconf
+       use debug && myconf="--enable-debug"
+
+       econf ${myconf}
+}