media-libs/cogl: Restore -f in rm -rvf
authorMatt Turner <mattst88@gentoo.org>
Sat, 23 Nov 2019 18:21:20 +0000 (13:21 -0500)
committerMatt Turner <mattst88@gentoo.org>
Sat, 23 Nov 2019 19:44:00 +0000 (14:44 -0500)
Because of the next patch we need to run eautoreconf, which somehow
causes this directory to not exist in the install. The -f was removed in
fc115d74f4ef ("media-libs/cogl: add missing mesa[egl] dep for USE=kms").
The commit message states

    Remove rm -f option usage while here (it makes the `|| die`
    useless and makes us not notice once this call isn't necessary
    anymore).

but cogl hasn't seen any real work in about three years, so I don't
think that's particularly important or likely to happen.

Bug: https://bugs.gentoo.org/692212
Signed-off-by: Matt Turner <mattst88@gentoo.org>
media-libs/cogl/cogl-1.22.4.ebuild

index 12bd445b80ff469b31b90d4cb11f319009a9fcc6..3265c8399ccc97ce40283591954293885d95784f 100644 (file)
@@ -114,5 +114,5 @@ src_install() {
        gnome2_src_install
 
        # Remove silly examples-data directory
-       rm -rv "${ED}/usr/share/cogl/examples-data/" || die
+       rm -rvf "${ED}/usr/share/cogl/examples-data/" || die
 }