dev-vcs/cvsps: refresh up to EAPI=7
authorSergei Trofimovich <slyfox@gentoo.org>
Sun, 10 Nov 2019 11:59:35 +0000 (11:59 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Sun, 10 Nov 2019 11:59:45 +0000 (11:59 +0000)
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-vcs/cvsps/cvsps-3.13-r2.ebuild [moved from dev-vcs/cvsps/cvsps-3.13-r1.ebuild with 90% similarity]

similarity index 90%
rename from dev-vcs/cvsps/cvsps-3.13-r1.ebuild
rename to dev-vcs/cvsps/cvsps-3.13-r2.ebuild
index 45e63d4b5dc4d1fda6b502142f4f86b624a3f89c..1d9ca2cea5f53da0f707cd8cce8afd829e29a2e1 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=7
 
 inherit eutils toolchain-funcs
 
@@ -20,10 +20,13 @@ DEPEND="${RDEPEND}
 
 RESTRICT=test # upstream does not ship tests
 
+PATCHES=("${FILESDIR}"/${P}-make.patch)
+
 src_prepare() {
+       default
+
        local gentoo_name=${PN}-3
 
-       epatch "${FILESDIR}"/${P}-make.patch
        mv ${PN}.asc ${gentoo_name}.asc || die
        sed -i "s/${PN}/${gentoo_name}/g" ${gentoo_name}.asc || die
        sed -i "s/PROG         = cvsps/PROG         = ${gentoo_name}/" Makefile || die
@@ -34,5 +37,6 @@ src_prepare() {
 
 src_install() {
        default
+
        dodoc README
 }