sys-devel/kgcc64: Version 7.3.0.
authorJeroen Roovers <jer@gentoo.org>
Sat, 24 Feb 2018 10:41:54 +0000 (11:41 +0100)
committerJeroen Roovers <jer@gentoo.org>
Sat, 24 Feb 2018 10:54:03 +0000 (11:54 +0100)
Package-Manager: Portage-2.3.24, Repoman-2.3.6

sys-devel/kgcc64/Manifest
sys-devel/kgcc64/kgcc64-7.3.0.ebuild [new file with mode: 0644]

index 2da8be43fe0ce15b30b8b184e27f59eda0da5a74..61f2e3702cf158a4985c0f9ef73ec137e32450c6 100644 (file)
@@ -32,3 +32,5 @@ DIST gcc-6.4.0-patches-1.0.tar.bz2 7577 BLAKE2B 56f7f9722ba446d44753504616b877b5
 DIST gcc-6.4.0.tar.xz 76156220 BLAKE2B 2018c338b28ea644cdd1b327cb0dfe7ee9aa2010357c93f7e71969f587c58d3fdfa2bb4c82a309490c48bc86924400022fa93f41dc6c4345878d1bc1d8204265 SHA512 02c60e54527c7adf584798d5251f8a0b80c93d5deafce82501b2c28e6692e0bd783927bbfc4bc527a863c0cccc025150a34740a9e29badb02d4b48e56a8aba90
 DIST gcc-7.1.0-patches-1.1.tar.bz2 6746 BLAKE2B 29ed4ff1ce6412a0c1a88f613377883ef5d391e7f681989295ac84dbb1950d99a17472d8b95a9351970ee5837cc3bfc4711101042c0e792c0bac3327bfa24d2e SHA512 1bf95a505dc6c37bf6924bb69fd0670c8f3355b6690c94edf4a4248649accbd426575b40cb7a473dfb0ae09a924b05619e5c633384bae0293edb670cfd0d3a30
 DIST gcc-7.2.0.tar.xz 62312628 BLAKE2B 35e4b732f1a4515fc1a9d4424797177112847588e600dc5531bc9bf72305619d4100e8fd9d945920245e704fc9ac5bc5e3dbd20be6c3af49e689fc5bd1eca10f SHA512 f853cd6530b4055d8d8289da74687cb4c6d5f363598d386332d31852b581bac76c3adb7d61889edec3b779f63d8646f0122840f12965ce4a4389ba535dbbb6e1
+DIST gcc-7.3.0-patches-1.0.tar.bz2 6757 BLAKE2B ffe6a69e61dc4379fc77b0bf21971ff6fe482edd315ae1243e55b147ad5794320816fbfc3f85ccebe34de080e2c5b718b60b59064aaf095e905c1b41d7c08168 SHA512 a86ffc03940afa12c44b919f861b9459a3cd460cd4680dce8316755021789530640977e90c4cff89be768fc62e0e24d9bee0a1ee76c537ad88c8f4ed07f1a73a
+DIST gcc-7.3.0.tar.xz 62462388 BLAKE2B dc8f132b21bd0543c3d9dd17557038aafe65675aa73c540954234a3c972b4c31c939149bd50183d072ab6c8d16919e19daeaaffd619ce2ccd62dbdf9a5bb3302 SHA512 ad41a7e4584e40e92cdf860bc0288500fbaf5dfb7e8c3fcabe9eba809c87bcfa85b46c19c19921b0cdf6d05483faede8287bb9ea120c0d1559449a70e602c8d4
diff --git a/sys-devel/kgcc64/kgcc64-7.3.0.ebuild b/sys-devel/kgcc64/kgcc64-7.3.0.ebuild
new file mode 100644 (file)
index 0000000..38de4ce
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+case ${CHOST} in
+       hppa*)    CTARGET=hppa64-${CHOST#*-};;
+       mips*)    CTARGET=${CHOST/mips/mips64};;
+       powerpc*) CTARGET=${CHOST/powerpc/powerpc64};;
+       s390*)    CTARGET=${CHOST/s390/s390x};;
+       sparc*)   CTARGET=${CHOST/sparc/sparc64};;
+       i?86*)    CTARGET=x86_64-${CHOST#*-};;
+esac
+export CTARGET
+TOOLCHAIN_ALLOWED_LANGS="c"
+GCC_TARGET_NO_MULTILIB=true
+
+PATCH_VER="1.0"
+inherit eutils toolchain
+
+DESCRIPTION="64bit kernel compiler"
+
+# Works on hppa and mips; all other archs, refer to bug #228115
+KEYWORDS="~hppa ~mips"
+
+RDEPEND=">=dev-libs/gmp-4.3.2
+       >=dev-libs/mpfr-2.4.2
+       >=dev-libs/mpc-0.8.1
+       >=sys-devel/gcc-config-1.4"
+# unlike every other target, hppa has not unified the 32/64 bit
+# ports in binutils yet
+DEPEND="${RDEPEND}
+       hppa? ( sys-devel/binutils-hppa64 )
+       !sys-devel/gcc-hppa64
+       !sys-devel/gcc-mips64
+       !sys-devel/gcc-powerpc64
+       !sys-devel/gcc-sparc64
+       >=sys-apps/texinfo-4.8
+       >=sys-devel/bison-1.875"
+
+pkg_postinst() {
+       toolchain_pkg_postinst
+
+       cd "${ROOT}"/usr/bin
+       local x
+       for x in gcc cpp ; do
+               cat <<-EOF >${CTARGET%%-*}-linux-${x}
+               #!/bin/sh
+               exec ${CTARGET}-${x} "\$@"
+               EOF
+               chmod a+rx ${CTARGET%%-*}-linux-${x}
+       done
+}