sys-apps/ed: rev bump
authorThomas Deutschmann <whissi@gentoo.org>
Mon, 11 Nov 2019 16:17:27 +0000 (17:17 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Mon, 11 Nov 2019 16:17:51 +0000 (17:17 +0100)
- EAPI bumped to EAPI=7

- Do not use econf

Closes: https://bugs.gentoo.org/611068
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
sys-apps/ed/ed-1.15-r1.ebuild [moved from sys-apps/ed/ed-1.15.ebuild with 88% similarity]

similarity index 88%
rename from sys-apps/ed/ed-1.15.ebuild
rename to sys-apps/ed/ed-1.15-r1.ebuild
index c6c5d7a96bc1425c039d38a588429aba91680e69..0226fe03f9c23bf996191f3419426ba372d38dd0 100644 (file)
@@ -1,7 +1,7 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI="7"
 
 inherit toolchain-funcs
 
@@ -21,10 +21,11 @@ RDEPEND=""
 
 src_configure() {
        # Upstream configure script is moronic.
-       econf \
+       ./configure \
                CC="$(tc-getCC)" \
                CFLAGS="${CFLAGS}" \
-               LDFLAGS="${CFLAGS} ${LDFLAGS}" \
+               LDFLAGS="${LDFLAGS}" \
                CPPFLAGS="${CPPFLAGS}" \
-               --bindir="${EPREFIX}/bin"
+               --bindir="${EPREFIX}/bin" \
+               --prefix="${EPREFIX}/usr"
 }