xfce-base/xfce4-panel: Make GTK+2 optional
authorMichał Górny <mgorny@gentoo.org>
Thu, 22 Aug 2019 10:03:33 +0000 (12:03 +0200)
committerMichał Górny <mgorny@gentoo.org>
Thu, 22 Aug 2019 11:14:54 +0000 (13:14 +0200)
Closes: https://bugs.gentoo.org/692714
Signed-off-by: Michał Górny <mgorny@gentoo.org>
xfce-base/xfce4-panel/metadata.xml
xfce-base/xfce4-panel/xfce4-panel-4.14.0.ebuild

index 359901b31db49298a74c801cf70f8a4560fe84ca..b307dd980e01b846a11025a3b135d4a1b2151530 100644 (file)
@@ -5,4 +5,7 @@
     <email>xfce@gentoo.org</email>
     <name>XFCE Team</name>
   </maintainer>
+  <use>
+    <flag name='gtk2'>Enable GTK+2 plugin support.</flag>
+  </use>
 </pkgmetadata>
index 0bba6eebc2370be4e2e91ba679f2ea8c462a9060..0598e0545e8d06ff9f23ba958f2a73f0e1c6d5d1 100644 (file)
@@ -12,12 +12,12 @@ SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
 LICENSE="GPL-2+ LGPL-2.1+"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="introspection vala"
+IUSE="+gtk2 introspection vala"
 REQUIRED_USE="vala? ( introspection )"
+RESTRICT="!gtk2? ( test )"
 
 RDEPEND=">=dev-libs/glib-2.42
        >=x11-libs/cairo-1
-       >=x11-libs/gtk+-2.20:2
        >=x11-libs/gtk+-3.22:3[introspection?]
        x11-libs/libX11
        x11-libs/libwnck:3
@@ -26,6 +26,7 @@ RDEPEND=">=dev-libs/glib-2.42
        >=xfce-base/libxfce4ui-4.13:=
        >=xfce-base/libxfce4util-4.13:=[introspection?]
        >=xfce-base/xfconf-4.13:=
+       gtk2? ( >=x11-libs/gtk+-2.20:2 )
        introspection? ( dev-libs/gobject-introspection:= )"
 DEPEND="${RDEPEND}
        vala? ( $(vala_depend) )
@@ -42,11 +43,9 @@ src_prepare() {
 
 src_configure() {
        local myconf=(
+               $(use_enable gtk2)
                $(use_enable introspection)
                $(use_enable vala)
-
-               # enable GTK+2 compatibility
-               --enable-gtk2
        )
 
        use vala && vala_src_prepare